HDU 5832 A water problem 大数取余

A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 650    Accepted Submission(s): 333


Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.
There is  73 days in Xixi a year and 137 days in Haha a year. 
Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.
 
Input
There are several test cases(about  5 huge test cases).
For each test, we have a line with an only integer N(0N), the length of N is up to 10000000.
 
Output
For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.
 
Sample Input
10001
0
333
 
Sample Output
Case #1: YES
Case #2: YES
Case #3: NO
 

Author

UESTC

 Source
 
 
ccpc的网络赛被虐的好惨啊 做完水题其他就下不了手了
还要加油  
 
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <vector>
#include <iomanip>
#include <math.h>
#include <map>
using namespace std;
#define FIN     freopen("input.txt","r",stdin);
#define FOUT    freopen("output.txt","w",stdout);
#define INF     0x3f3f3f3f
#define INFLL   0x3f3f3f3f3f3f3f
#define lson    l,m,rt<<1
#define rson    m+1,r,rt<<1|1
typedef long long LL;
typedef pair<int,int> PII;

const int MAXN = 10000005;

char s[MAXN];

int check(char s[], int mod){
    
    //将数字看成多项式的和  比如12345就是1*10^5+2*10^4+3*10^3+4*10^2+5*10^1
    //先把数求模和分开求再合起来求模结果是一样的
    
    LL sum = 0;
    int len = strlen(s);
    for( int i = 0; i < len ; i++){
        sum = sum*10 + s[i]-48;
        sum %= mod;
    }
    return sum;
}

int main()
{
    //FIN
    int cas = 1;
    while(~scanf("%s", s)){
        if(check(s, 137) == 0 && check(s, 73) == 0)  printf("Case #%d: YES\n",cas++);
        else  printf("Case #%d: NO\n",cas++);
    }

}

  

 

转载于:https://www.cnblogs.com/Hyouka/p/5774231.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值