HDU 2444 The Accomodation of Students(BFS判断是否为二分图)

Description:

There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other. 

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room. 

Calculate the maximum number of pairs that can be arranged into these double rooms. 
 

Input:

For each data set: 
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs. 

Proceed to the end of file. 

Output:

If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms. 
 

Sample Input:

4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6
 

Sample Output:

No
3
 
题意:有一些学生,他们之间有些互相认识,有些不认识,其中若A和B认识,B和C认识,并不代表A和C认识,现在提供互相认识的学生编号,问是否能将这些学生分成两组,同一组的学生互相不认识,如果可以,则分配给这些学生双人间,只有是朋友才能住双人间,问最多要准备几间房( 即问是否为二分图,若是,其最大匹配数是多少
#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
#define N 210
using namespace std;
int G[N][N], visit[N];
int vis[N], use[N], col[N];
int n, flag;
void BFS(int u) //判断是否为二分图
{
    int i, v;
    queue<int>Q;
    Q.push(u);
    visit[u] = 1;
    while (!Q.empty())
    {
        v = Q.front();
        Q.pop();
        for (i = 1; i <= n; i++)
        {
            if (v == i) continue;
            if (!visit[i] && col[i] == 0 && G[v][i])
            {
                col[i] = -1;
                visit[i] = 1;     //第一组的学生标记为1,他们的朋友标记为-1,若在查找中发现自己和朋友的标记一致,则说明不能分为互不认识的两组
                Q.push(i);
            }
            else if (col[i] == col[v] && G[v][i])
                flag = 1; //自己和朋友标记相同,则不是二分图
        }
    }
}
int Find(int u) //匈牙利算法查找最大匹配数
{
    int i;
    for (i = 1; i <= n; i++)
    {
        if (!vis[i] && G[u][i])
        {
            vis[i] = 1;
            if (!use[i] || Find(use[i]))
            {
                use[i] = u;
                return 1;
            }
        }
    }
    return 0;
}
int main ()
{
    int m, ans, i, a, b;
    while (scanf("%d%d", &n, &m) != EOF)
    {
        memset(G, 0, sizeof(G));
        memset(use, 0, sizeof(use));
        memset(visit, 0, sizeof(visit));
        memset(col, 0, sizeof(col));
        ans = 0;
        while (m--)
        {
            scanf("%d%d", &a, &b);
            G[a][b] = 1;
        }
        flag = 0;
        col[1] = 1;
        BFS(1);
        if (flag) printf("No\n");
        else
        {
            for (i = 1; i <= n; i++)
            {
                memset(vis, 0, sizeof(vis));
                if (Find(i)) ans++;
            }
            printf("%d\n", ans);
        }
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/syhandll/p/4721270.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
CSDN IT狂飙上传的代码均可运行,功能ok的情况下才上传的,直接替换数据即可使用,小白也能轻松上手 【资源说明】 基于MATLAB实现的有限差分法实验报告用MATLAB中的有限差分法计算槽内电位;对比解析法和数值法的异同点;选取一点,绘制收敛曲线;总的三维电位图+使用说明文档 1、代码压缩包内容 主函数:main.m; 调用函数:其他m文件;无需运行 运行结果效果图; 2、代码运行版本 Matlab 2020b;若运行有误,根据提示GPT修改;若不会,私信博主(问题描述要详细); 3、运行操作步骤 步骤一:将所有文件放到Matlab的当前文件夹中; 步骤二:双击打开main.m文件; 步骤三:点击运行,等程序运行完得到结果; 4、仿真咨询 如需其他服务,可后台私信博主; 4.1 期刊或参考文献复现 4.2 Matlab程序定制 4.3 科研合作 功率谱估计: 故障诊断分析: 雷达通信:雷达LFM、MIMO、成像、定位、干扰、检测、信号分析、脉冲压缩 滤波估计:SOC估计 目标定位:WSN定位、滤波跟踪、目标定位 生物电信号:肌电信号EMG、脑电信号EEG、心电信号ECG 通信系统:DOA估计、编码译码、变分模态分解、管道泄漏、滤波器、数字信号处理+传输+分析+去噪、数字信号调制、误码率、信号估计、DTMF、信号检测识别融合、LEACH协议、信号检测、水声通信 5、欢迎下载,沟通交流,互相学习,共同进步!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值