POJ3487[稳定婚姻]

本文探讨了稳定婚姻问题,并通过Gale-Shapley算法找到了一种男士优先的稳定配对方案。该算法确保每位男士都能获得最优伴侣,同时也确保了配对的稳定性。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

The Stable Marriage Problem
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2974 Accepted: 1267

Description

The stable marriage problem consists of matching members of two different sets according to the member’s preferences for the other set’s members. The input for our problem consists of:
  • a set M of n males;
  • a set F of n females;
  • for each male and female we have a list of all the members of the opposite gender in order of preference (from the most preferable to the least).

A marriage is a one-to-one mapping between males and females. A marriage is called stable, if there is no pair (m, f) such that f ∈ F prefers m ∈ M to her current partner and m prefers f over his current partner. The stable marriage A is called male-optimal if there is no other stable marriage B, where any male matches a female he prefers more than the one assigned in A.

Given preferable lists of males and females, you must find the male-optimal stable marriage.

Input

The first line gives you the number of tests. The first line of each test case contains integer n (0 < n < 27). Next line describes n male and n female names. Male name is a lowercase letter, female name is an upper-case letter. Then go n lines, that describe preferable lists for males. Next n lines describe preferable lists for females.

Output

For each test case find and print the pairs of the stable marriage, which is male-optimal. The pairs in each test case must be printed in lexicographical order of their male names as shown in sample output. Output an empty line between test cases.

Sample Input

2
3
a b c A B C
a:BAC
b:BAC
c:ACB
A:acb
B:bac
C:cab
3
a b c A B C
a:ABC
b:ABC
c:BCA
A:bac
B:acb
C:abc

Sample Output

a A
b B
c C

a B
b A
c C

Source


题目大意
    有N位女士和N位男士,每位男士或者女士都对对方有个评价。
他们会形成N对夫妻,如果A和a结婚,B和b结婚,但是A更偏爱b而非a而且b也更偏爱A而非B,那么这种婚姻是不稳定的 .
求 一个稳定的 婚姻 配对。

    题目要求是男士优先,也就是男士优先表白,肯定会从最喜欢的开始表白,如果对方没有男友或者表白的男士优于当前男友,就会抛弃原来的男友,而接受表白的男士,男士也成功脱光。否则男士会被拒绝,便只能考虑下一个喜欢的女士。直到所有人都脱光,不存在拒绝情况为止。
采用 Gale-Shapley算法 :
    男生不停的求婚,女生不停地拒绝.
    算法保证:每一位男性得到的伴侣都是所有可能的稳定婚姻搭配方案中最理想的,同时每一位女性得到的伴侣都是所有可能的稳定婚姻搭配方案中最差的。
是不是只有唯一的稳定婚姻呢,觉得如果没有对两个人的评价完全相同的情况下,应该是唯一的.


 

  • Source Code
    #include<cstdio>
    #include<cstring>
    #include<queue>
    #include<algorithm>
    using namespace std;
    const int N=30;
    int malelike[N][N],femalelike[N][N];
    int malechoice[N],femalechoice[N];
    int malename[N],femalename[N];
    int T,couple;char str[N];
    queue<int>freemale;
    int main(){
    	scanf("%d",&T);
    	while(T--){
    		while(!freemale.empty()) freemale.pop();
    		scanf("%d",&couple);
    		for(int i=0;i<couple;i++) scanf("%s",str),freemale.push(malename[i]=str[0]-'a');
    		sort(malename,malename+couple);
    		for(int i=0;i<couple;i++) scanf("%s",str),femalename[i]=str[0]-'A';
    		for(int i=0;i<couple;i++){
    			scanf("%s",str);
    			for(int j=0;j<couple;j++){
    				malelike[i][j]=str[j+2]-'A';
    			}
    		}
    		for(int i=0;i<couple;i++){
    			scanf("%s",str);
    			for(int j=0;j<couple;j++){
    				femalelike[i][str[j+2]-'a']=couple-j;
    			}
    			femalelike[i][couple]=0;
    		}
    		memset(malechoice,0,(couple+2)<<2);
    		for(int i=0;i<couple;i++) femalechoice[i]=couple;
    		while(!freemale.empty()){
    			int male=freemale.front();
    			int female=malelike[male][malechoice[male]];
    			if(femalelike[female][male]>femalelike[female][femalechoice[female]]){
    				freemale.pop();
    				if(femalechoice[female]!=couple){
    					freemale.push(femalechoice[female]);
    					malechoice[femalechoice[female]]++;
    				}
    				femalechoice[female]=male;
    			}
    			else malechoice[male]++;
    		}
    		for(int i=0;i<couple;i++) printf("%c %c\n",malename[i]+'a',malelike[malename[i]][malechoice[malename[i]]]+'A');
    		if(T) putchar('\n');
    	}
    	return 0;
    }
 
 


转载于:https://www.cnblogs.com/shenben/p/6536920.html

当前提供的引用内容并未提及关于POJ平台上编号为3487的问题描述或解决方案。然而,可以通过分析已知的其他POJ题目来推测解决此类问题的一般方法。 通常情况下,在处理编程竞赛中的图论、搜索算法或其他类型的计算问题时,需要明确以下几个方面: 1. **输入数据结构**:了解输入的数据形式以及如何解析这些数据。 2. **核心算法设计**:确定解决问题的核心算法(如广度优先搜索[BFS]、深度优先搜索[DFS]、动态规划等)。 3. **边界条件与优化策略**:识别可能存在的特殊测试用例并采取相应的优化措施。 尽管未提供具体针对POJ 3487的信息,但可以借鉴类似的BFS应用实例[^1] 或者皇后放置问题中的回溯法实现逻辑[^2] 来构建解题框架。如果该问题是基于路径寻找或者状态转移,则很可能涉及队列操作配合邻接表表示连通关系;如果是组合排列类挑战则需注意剪枝技巧减少不必要的递归调用次数。 以下是假设此题属于最短路经范畴的一个基础伪代码模板作为参考: ```python from collections import deque def bfs(start_node, target_node): visited = set() queue = deque([(start_node, 0)]) # (current node, steps) while queue: current, step_count = queue.popleft() if current == target_node: return step_count for neighbor in get_neighbors(current): # function defining adjacency list logic if neighbor not in visited: visited.add(neighbor) queue.append((neighbor, step_count + 1)) return -1 # no path found between start and target nodes. ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值