HDU 2451 Simple Addition Expression

Simple Addition Expression

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1508    Accepted Submission(s): 576


Problem Description
A luxury yacht with 100 passengers on board is sailing on the sea in the twilight. The yacht is ablaze with lights and there comes out laughers and singing from the hall where an evening party is in full swing. People are singing, dancing and enjoying themselves.

The yacht is equipped with the most advanced navigation and driving system which can all be manipulated by a computer. When the captain notices that there is only gentle breeze and the sea waves are not high, he starts the autopilot. The yacht sails forward smoothly, ploughs the waves. When it’s completely dark, the passengers start to feel a little funny for sudden forward rushes or sudden decelerations or slight swings. The captain immediately walks to the driving platform and switches the autopilot to human manipulation. The yacht returns back to normal and the party restarts. Laughers come back, too.

The captain summons the engineer on board to do a thorough check of the navigation system. It turns out that only the computer is out of order, but the exact failure is still unclear. There is a computer scientist among the passengers who is also invited to the cab to give a hand. He first inputs several groups of data to test the computer. When he inputs 1+2+3, the computer outputs 6, which is exactly right. But when he inputs 4+5+6, the computer outputs 5, which is wrong. Then he inputs 12+13+14, and gets 39, another right answer, while he inputs 14+15+16, and gets 35, another wrong answer. After the test, the computer scientist says smilingly: “the failure is clear now. The computer's adder can not carry." After excluding the failure, the captain restarts the autopilot and the yacht returns back to normal, sailing smoothly on the sea.

The captain and the engineer invite the computer scientist to sit down and have a talk. The computer scientist tells a story as following:

A former mathematician defined a kind of simple addition expression. 
If there is an expression (i) + (i+1) + (i+2), i>=0, when carried out additive operations, no position has a carry, it is called simple addition expression.

For instance, when i equals 0, 0+1+2 is a simple addition expression, meanwhile when i equals 11, 11+12+13 is a simple addition expression, too. Because of that no position has a carry.

However, when i equals 3, 3+4+5 is not a simple addition expression, that is because 3+4+5 equals 12, there is a carried number from unit digit to tens digit. In the same way, when i equals 13, 13+14+15 is not a simple addition expression, either. However, when i equals 112, 112+113+114 is a simple addition expression. Because 112+113+114 equals 339, there is no carry in the process of adding.

when the students have got the definition of simple addition expression, the mathematician puts forward a new question: for a positive integer n, how many simple addition expressions exist when i<n. In addition, i is the first number of a simple addition expression.

when the value of n is large enough, the problem needs to be solved by means of computer.

 

 

Input
There are several test cases, each case takes up a line, there is an integer n (n<10^10).

 

 

Output
Output the number of all simple addition expressions when i<n.

 

 

Sample Input
1
2
3
4
10
11
 
Sample Output
1
2
3
3
3
4

 

题意是要判断前n位数字(不包括n),有多少个数字 i 跟前面两个 i+1 , i+2 ,相加时不进位 。

符合要求的数字就是个位 0 ~ 2 ,其余位 0 ~ 3。

用一个dfs就可以搜出来了。

对于当前位是 x 的话 , 若果 x > 3 , 可以直接得出可以构成  [ 4^(位数-1) * 3 ] 个数

若果 x <= 3 的话 , 就可以构成 [  (x-1)*4^(位数-1)*3 + 后面的位能组成数字的数目(递归求) ]。

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <algorithm>
using namespace std;
#define root 1,n,1
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define lr rt<<1
#define rr rt<<1|1
typedef long long LL;
const int oo = 1e9+7;
const double PI = acos(-1.0);
const double eps = 1e-6 ;
const int N = 1010;
int num[N], cnt ;
LL f[N] , n;
void init() {
    f[0] = 0 ; f[1] = 3 ;
    for( int i = 2 ; i <= 11 ; ++i ) f[i] = f[i-1] * 4 ;
}
LL cal( int pos ) {
    if( pos == 1 ) {
        return min ( 3LL , (LL)num[pos] + 1 ) ;
    }
    else {
        if( num[pos] <= 3 ) return f[ pos-1 ] * num[pos] + cal( pos - 1 ) ;
        else return f[pos] ;
    }
}
int main()
{
//    freopen("in.txt","r",stdin);
    ios::sync_with_stdio(false);
    init();
    while( cin >> n ) {
        if( !n ){ puts("0"); continue ; }
        if( n == 1  ){ puts("1"); continue ; }
        n--; cnt = 1 ;
        while( n ) {
            num[cnt++] = n % 10 ;
            n /= 10 ;
        }
        cout << cal( cnt - 1 ) << endl ;
    }
}
View Code

 

转载于:https://www.cnblogs.com/hlmark/p/4187878.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值