POJ3278:Catch That Cow(BFS)

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 82031 Accepted: 25785

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source


用BFS即可,有地方需要注意,①visit数组要开到200000以上,否则“心灵传输”时可能会下标越界,②当上一个状态坐标超过K时不用向前走或“心灵传输”了,防止越界和优化时间。

# include <stdio.h>
# include <queue>
# include <string.h>
using namespace std;
struct node
{
    int x, step;
};
queue<node>Q;
int vis[200001];
int bfs(int pos, int target)
{
    node tmp;
    tmp.x = pos;
    tmp.step = 0;
    Q.push(tmp);
    while(!Q.empty())
    {
        node tmp = Q.front();
        if(tmp.x == target)
            return tmp.step;
        if(tmp.x > 0 && !vis[tmp.x-1])
        {
            node temp;
            vis[tmp.x-1] = 1;
            temp.x = tmp.x-1;
            temp.step = tmp.step + 1;
            Q.push(temp);
        }
        if(tmp.x <= target && !vis[tmp.x+1])
        {
            node temp;
            vis[tmp.x+1] = 1;
            temp.x = tmp.x+1;
            temp.step = tmp.step + 1;
            Q.push(temp);
        }
        if(tmp.x <= target && !vis[(tmp.x)<<1])
        {
            node temp;
            vis[(tmp.x)<<1] = 1;
            temp.x = (tmp.x)<<1;
            temp.step = tmp.step + 1;
            Q.push(temp);
        }
        Q.pop();
    }
}
int main()
{
    int n, m;
    while(scanf("%d%d",&n,&m) != EOF)
    {
        if(m <= n)
        {
            printf("%d\n",n-m);
            continue;
        }
        memset(vis, 0, sizeof(vis));
        while(!Q.empty())
            Q.pop();
        printf("%d\n",bfs(n, m));
    }
    return 0;
}


转载于:https://www.cnblogs.com/junior19/p/6730085.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值