hrbust 训练赛 hdu 1017

1、链接:

http://acm.hrbust.edu.cn/vj/index.php?/vj/index.php?c=&c=contest-contest&cid=278#problem/7

2、题目:

Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
Sample Input

1

10 1
20 3
30 4
0 0
Sample Output

Case 1: 2
Case 2: 4
Case 3: 5

3、解题分析:

根据题意知:求在(a, b)区间内(a^2 + b^2 +m)/a*b的结果是一个整形数的个数,即(a^2 + b^2 +m)%(a*b)==0暴力求解即

注意:注意输出格式每一大组之间有一个换行

4、代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int N;
    scanf("%d",&N);
    int n,m;
    while(N--)
    {
        int cas = 1;
        while(~scanf("%d%d",&n,&m)){
            int count = 0;
            if(n == 0 && m ==0 )
                break;
            for(int i = 1; i < n; i++)
            {
                for(int j = i+1; j< n; j++)
                {
                    if((i*i + j*j + m)%(i*j) == 0)
                    {
                        count++;
                    }
                }
            }
            printf("Case %d: %d\n",cas++,count);
        }
        if(N)
            printf("\n");
    }
    return 0;
}
/*
1

10 1
20 3
30 4
0 0
*/

 

转载于:https://www.cnblogs.com/mcgrady_ww/p/7784549.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值