hrbust 训练赛 - - - hdu 1016

1、链接:

http://acm.hrbust.edu.cn/vj/index.php?c=problem-problem&id=2178

题目:

 

Description

 

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

 

Note: the number of first circle should always be 1.

 

 

 

Input

 

n (0 < n < 20).
Output

 

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

 

You are to write a program that completes above process.

 

Print a blank line after each case.
Sample Input

 

6
8
Sample Output

 

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

 

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
Source

 

Asia 1996, Shanghai (Mainland China)

 

2、解题分析:

题意:给定数n,要求1~n的n个数 从1开始 组成一个环,没相邻的两个数的和为质数(素数)。ps:首尾相接处也要判断

解法:利用dfs实现全排列,从全排列中筛选符合条件的,但是要一边DFS一边判断目前状态是否合法,可以实现优化。

 

3、代码

#include<bits/stdc++.h>
using namespace std;

int n;
int step;
int vis[105];
int ans[105];

int prime[12] = {2,3,5,7,11,13,17,19,23,29,31,37};//打表

bool primer_num(int x) //素数判断
{
    for(int i = 0; i < 12; i++)
        if(x == prime[i])
            return true;
    return false;
}

void dfs(int step)
{
    if(step == n + 1)
    {
        if(primer_num(ans[n] + ans[1])){
            for(int i = 1; i <= n; i++)
            {
                printf("%d",ans[i]);
                if(i != n)
                    printf(" ");
                else
                {
                    printf("\n");
                }
            }
        }
    }

    for(int i = 2 ; i <= n; i++)
    {
        if(vis[i] == 0 && primer_num(ans[step-1] + i))
        {
            vis[i] = 1;
            ans[step] = i;
            dfs(step + 1);
            vis[i] = 0;
        }
    }
}
int main()
{
    int cas = 1;
    while(~scanf("%d",&n))
    {
        memset(vis, 0 ,sizeof(vis));
        printf("Case %d:\n",cas++);
        ans[1] = 1;
        dfs(2);
        puts("");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/mcgrady_ww/p/7755856.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值