【问题描述】
You are to write a program that has to generate all possible words from a given set of letters. Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba". In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.
Input
The input file consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different.
Output
For each word in the input file, the output file should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter.
Sample Input
3
aAb
abc
acba
Sample Output
Aab
Aba
aAb
abA
bAa
baA
abc
acb
bac
bca
cab
cba
aabc
aacb
abac
abca
acab
acba
baac
baca
bcaa
caab
caba
cbaa
【解题思路】
简单题、搜索。递归。
【具体实现】
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
char data[ 200 ];
bool used[ 200 ];
char last[ 200 ];
char save[ 200 ];
int low( char c )
{
if ( c >= 'a' && c <= 'z' )
return c;
return c + 'a'-'A';
}
int cmp( const void* a, const void* b )
{
char *p = (char *)a;
char *q = (char *)b;
if ( abs(*p-*q) == 'a'-'A' )
return *p - *q;
return low(*p) - low(*q);
}
void dfs( int l, int d )
{
/* 去重,从前向后查询,遇到处理位置和上次一样即重复。 */
int flag = 1;
for ( int i = 0 ; i < d ; ++ i )
if ( last[i] != save[i] ) {
flag = 0;break;
}
if ( d && flag ) return;
if ( l == d ) {
strcpy(last,save);
printf("%s\n",save);
return;
}
for ( int i = 0 ; i < l ; ++ i )
if ( !used[i] ) {
used[i] = 1;
save[d] = data[i];
dfs( l, d+1 );
used[i] = 0;
}
}
int main()
{
int t;
while ( scanf("%d",&t) != EOF )
while ( t -- ) {
memset( used, 0, sizeof(used) );
memset( last, 0, sizeof(last) );
memset( save, 0, sizeof(save) );
scanf("%s",data);
int l = strlen(data);
qsort( data, l, sizeof(char), cmp );
dfs( l, 0 );
}
return 0;
}
【额外补充】
是字典序,不是ASC序,AaBb...