Router1 S0/0 <----> Router2 S0/0
Router1 S0/1 <----> Router3 S0/0
Router2 S0/1 <----> Router4 S0/0
Router3 S0/1 <----> Router5 S0/0
Router4 F1/0 <----> Router5 F1/0


R1:
enable
conf t
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synch
exit
hostname R1
interface serial 0/0
ip address 12.0.0.1 255.255.255.0
no shutdown
interface serial 0/1
ip address 13.0.0.1 255.255.255.0
no shutdown
exit
ip route 4.4.4.4 255.255.255.255 12.0.0.2
ip route 5.5.5.5 255.255.255.255 13.0.0.3
ip route 24.0.0.0 255.255.255.0 12.0.0.2
ip route 35.0.0.0 255.255.255.0 13.0.0.3
end
R2:
enable
conf t
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synch
exit
hostname R2
interface serial 0/0
ip address 12.0.0.2 255.255.255.0
no shutdown
interface serial 0/1
ip address 24.0.0.2 255.255.255.0
no shutdown
exit
ip route 4.4.4.4 255.255.255.255 24.0.0.4
ip route 5.5.5.5 255.255.255.255 12.0.0.1
ip route 13.0.0.0 255.255.255.0 12.0.0.1
ip route 35.0.0.0 255.255.255.0 12.0.0.1
end

R3:
enable
conf t
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synch
exit
hostname R3
interface serial 0/0
ip address 13.0.0.3 255.255.255.0
no shutdown
interface serial 0/1
ip address 35.0.0.3 255.255.255.0
no shutdown
exit
ip route 4.4.4.4 255.255.255.255 13.0.0.1
ip route 5.5.5.5 255.255.255.255 35.0.0.5
ip route 12.0.0.0 255.255.255.0 13.0.0.1
ip route 24.0.0.0 255.255.255.0 13.0.0.1
ip route 35.0.0.0 255.255.255.0 35.0.0.5
end

R4:
enable
conf t
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synch
exit
hostname R4
interface serial 0/0
ip address 24.0.0.4 255.255.255.0
no shutdown
interface loopback 0
ip address 4.4.4.4 255.255.255.255
no shutdown
exit
ip route 5.5.5.5 255.255.255.255 24.0.0.2
ip route 12.0.0.0 255.255.255.0 24.0.0.2
ip route 13.0.0.0 255.255.255.0 24.0.0.2
end

R5:
enable
conf t
no ip domain-lookup
line console 0
exec-timeout 0 0
logging synch
exit
hostname R5
interface serial 0/0
ip address 35.0.0.5 255.255.255.0
no shutdown
interface loopback 0
ip address 5.5.5.5 255.255.255.255
no shutdown
exit
ip route 4.4.4.4 255.255.255.255 35.0.0.3
ip route 12.0.0.0 255.255.255.0 35.0.0.3
ip route 13.0.0.0 255.255.255.0 35.0.0.3
ip route 24.0.0.0 255.255.255.0 35.0.0.3
end


配置完成后个路由能互相ping通,最基础的实验