AtCoder Grand Contest 012 A - AtCoder Group Contest(贪心)

Time limit : 2sec / Memory limit : 256MB

Score : 300 points

Problem Statement

There are 3N participants in AtCoder Group Contest. The strength of the i-th participant is represented by an integer ai. They will form N teams, each consisting of three participants. No participant may belong to multiple teams.

The strength of a team is defined as the second largest strength among its members. For example, a team of participants of strength 152 has a strength 2, and a team of three participants of strength 323 has a strength 3.

Find the maximum possible sum of the strengths of N teams.

Constraints

  • 1≤N≤105
  • 1≤ai≤109
  • ai are integers.

Input

Input is given from Standard Input in the following format:

N
a1 a2  a3N

Output

Print the answer.


Sample Input 1

Copy
2
5 2 8 5 1 5

Sample Output 1

Copy
10

The following is one formation of teams that maximizes the sum of the strengths of teams:

  • Team 1: consists of the first, fourth and fifth participants.
  • Team 2: consists of the second, third and sixth participants.

Sample Input 2

Copy
10
1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000

Sample Output 2

Copy
10000000000

The sum of the strengths can be quite large.


****************************************************************************************************************************************************

题意:给你3N个数,要你组成N只team,每一只team3人 :D

每一只team的值为3人的中间值。求出每一只对的总值。

解题思路:先sort一下。可以得到 a1, a2, a3 ~~~~ aN aN+1 ~~~~ a2N a2N+1 ~~~~~a3N;

要求和最大, 所以中间那个要最大,a1, a3N, a3N-1 组成一组

很容易就可以知道贪心的策略了。

****************************************************************************************************************************************************

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long LL;
const int maxn = 300000+10;
int a[maxn];
int main()
{
    ios::sync_with_stdio(0);
    int N;
    cin >> N;
    for(int i=0;i<3*N;i++)  cin >> a[i];
    sort(a, a+3*N);
    LL ans = 0;
    int j=3*N - 2;
    for(int i=1;i<=N;i++)
    {
        ans += a[j];
        j-=2;
    }
    cout << ans << endl;
    return 0;
}



 

转载于:https://www.cnblogs.com/denghaiquan/p/6666085.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值