ZOJ 1151 Word Reversal

Word Reversal

Time Limit: 2 Seconds      Memory Limit: 65536 KB

For each list of words, output a line with each word reversed without changing the order of the words.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Input

You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.


Output

For each test case, print the output on one line.


Sample Input

1

3
I am happy today
To be or not to be
I want to win the practice contest


Sample Output

I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc


题意概括:把输入的字符串以空格为界限进行逆置

解题思路:模拟一下整个过程即可

AC代码:

#include<stdio.h>
#include<string.h>

int main(void)
{
	char a[1005];
	int N, i, j, len, k, n;
	scanf("%d", &N);
	while(N--)
	{
		scanf("%d", &n);
		getchar(); 
		while(n --)
		{
		k = 0;
		gets(a);
		len = strlen(a);
		for(i = 0; a[k] != '\0'; i ++)
		{
			if(i == 0)
			{
				j = i;
				while(a[j] != ' ' && a[j] != '\0')
				{
					j ++;
				}
				if(a[j] == '\0')
				{
					k = j;
				}
				j = j - 1;
				while(i <= j)
				{
					printf("%c", a[j]);
					j --;
				}
			}
			else
			{
				if(a[i] == ' ')
				{
					j = i;
					j ++;
					while(a[j] != ' ' && a[j] != '\0')
					{
						j ++;
					}
					while(i < j && a[j] != '\0')
					{
						printf("%c", a[j]);
						j --;
					}
					if(a[j] == '\0')
					{
						k = j;	
					}
					if(a[j] == '\0')
					{
						j --;
						printf(" %c", a[j]);
						while(i + 1 < j && a[j] != '\0')
						{
							j --;
							printf("%c", a[j]);
							
						}
					}
					
				}
			}
		
		}
			printf("\n");
		}
		if(N != 0)
		{
			printf("\n");
		}
	}
	
	return 0;
} 

错误原因:1因为是presentation error,所以一直以为是数字输入的问题,其实是因为在输出的时候,字符串的尾部多输出的一个空格。。。。所以会PE。

感受:居然废寝忘食地在数字和字符串衔接的地方找了半天。。。。
敲打

转载于:https://www.cnblogs.com/moon13579/p/8652693.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值