大菲波数

Problem Description 
 
Fibonacci数列,定义如下:f(1)=f(2)=1,f(n)=f(n-1)+f(n-2) n>=3;
计算第n项Fibonacci数值。

Input

输入第一行为一个整数N,接下来N行为整数m(1<=m<=1000)。

Output

输出为N行,每行为对应的f(m)。

Sample Input
3
2
3
4
Sample Output
1
2
3
 
 

 

 

#include<iostream>
#include<list>
#include<string>
using namespace std;


list<int> BigAddList(list<int> La,list<int> Lb )
{
list<int> Lc;
list<int> ::iterator it1,it2;
it1=La.begin();
it2=Lb.begin();

int carry=0;
while(it1!=La.end()||it2!=Lb.end())
{
int c=carry;
if(it1!=La.end())
{
c=c+(*it1);
it1++;
}
if(it2!=Lb.end())
{
c=c+(*it2);
it2++;
}
carry=c/10;
Lc.push_back(c%10);
}
if(carry>0) Lc.push_back(carry);
Lc.reverse();
return Lc;
}

 

int main()
{
int o;
cin>>o;
for(int v=0;v<o;v++ )
{
list<int>La,Lb,Lc,Ld;
Lc.push_back(1);
La.push_back(1);
Lb.push_back(1);
int T;
cin>>T;
for(int j=3;j<=T;j++)
{
Lc=BigAddList(La,Lb);
La=Lb;
Lb=Lc;
Lb.reverse();

}

for(list<int>::iterator it=Lc.begin();it!=Lc.end();it++)
{
cout<<*it;
}
Lc.clear();
cout<<endl;
}
}

转载于:https://www.cnblogs.com/ilovetheworld/p/10573162.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值