POJ 2349 Arctic Network (最小生成树Kruskal)

 

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13
题意:
  可以这么理解:有S个卫星可以免费通信,相当于有S-1条权值为0的边,然后剩下求出剩下权值最大的一条边。
题解:
   当然是最小生成树里最大的m-1条边权值设为0,然后记录剩下最大的那条边的权值就好了。
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn=505;
int par[maxn];
int n,m;
int cas;
struct edge
{
    int u,v;
    double cost;
}es[maxn*maxn];
struct node
{
    int x,y;
}p[maxn];
double dis(node a,node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
bool cmp(edge a,edge b)
{
    return a.cost<b.cost;
}
void init()
{
    for(int i=1;i<=n;i++)
        par[i]=i;
}
int find(int x)
{
    return x==par[x]?x:par[x]=find(par[x]);
}
void unite(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x!=y)
        par[x]=y;
}
bool same(int x,int y)
{
    return find(x)==find(y);
}
double kruskal()
{
    init();
    sort(es,es+cas,cmp);
    int cnt=0;
    for(int i=0;i<cas;i++)
    {
        edge e=es[i];
        if(!same(e.u,e.v))
        {
            unite(e.u,e.v);
            if(++cnt==n-m)
                return e.cost;
        }
    }
    return 0;
}
int main()
{    
    int t;
    cin>>t;
    while(t--)
    {
        cin>>m>>n;
        for(int i=0;i<n;i++)
            cin>>p[i].x>>p[i].y;
        cas=0;
        for(int i=0;i<n;i++)
            for(int j=i+1;j<n;j++)
            {
                double d=dis(p[i],p[j]);
                es[cas].u=i+1,es[cas].v=j+1;
                es[cas].cost=d;
                cas++;
            }
        printf("%.2lf\n",kruskal());
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/orion7/p/7399820.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值