How Many Roads?

1005: 【2012四川省热身赛】Problem B. How Many Roads?

Time Limit: 1 Sec  Memory Limit: 32 MB

Description

As a director of cities transportation construction, Elfness is given a mission to connect n cities by
a lot of roads. Of course, the more roads to be built, the more convenient it would be. But if there
are two roads cross each other, traffic accidents may happen. So it means on Elfness’s ACM(All
Cities’ Map), there are no cross roads. And now, Elfness wants to know how many roads can be
built at most(Attention: a road won’t have to be a segment, it can be a straight line or a ray)?

Input

The first line of input is a single number T(T < 1000),means the number of test cases.Then T
cases followed, each case contains only one line with a single number n(0 < n ≤ 10 8),the number
of cities.

Output

For each test case,you should output one line. First, output “Case #t: ”, t means the number
of the test case which is from 1 to T. Then, output an integer indicates the maximal number of
roads can be built.

Sample Input

3
1
2
3

Sample Output

Case #1: 0
Case #2: 1
Case #3: 3

HINT

Source

2012年西部首届暨四川省第4届ACM-ICPC大学生程序设计竞赛热身赛

当城市等于4个的时候,就比3个城市的时候多三条路

当城市等于5个的时候,就比4个城市的时候多三条路

依次类推

#include<stdio.h>
int main()
{
    int n,m,i,t=1;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&m);
        if(m>0&&m<=100000000)
        {
            if(m==1)
                printf("Case #%d: %d\n",t++,0);
            else if(m>1&&m<=3)
                printf("Case #%d: %d\n",t++,2*m-3);
            else
                printf("Case #%d: %d\n",t++,(m-2)*3);
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/tianmin123/p/4734898.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕业设计,基于SpringBoot+Vue+MySQL开发的公寓报修管理系统,源码+数据库+毕业论文+视频演示 现代经济快节奏发展以及不断完善升级的信息化技术,让传统数据信息的管理升级为软件存储,归纳,集中处理数据信息的管理方式。本公寓报修管理系统就是在这样的大环境下诞生,其可以帮助管理者在短时间内处理完毕庞大的数据信息,使用这种软件工具可以帮助管理人员提高事务处理效率,达到事半功倍的效果。此公寓报修管理系统利用当下成熟完善的Spring Boot框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的MySQL数据库进行程序开发。公寓报修管理系统有管理员,住户,维修人员。管理员可以管理住户信息和维修人员信息,可以审核维修人员的请假信息,住户可以申请维修,可以对维修结果评价,维修人员负责住户提交的维修信息,也可以请假。公寓报修管理系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。 关键词:公寓报修管理系统;Spring Boot框架;MySQL;自动化;VUE
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值