一组简单一点的题目(五)R - Rectangles

题目:R - Rectangles
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
Sample Output
1.00
56.25

大意:输入四个坐标,8个数,前两个坐标为第一个矩形的对角线的两个点,后两个坐标为第二个矩形的对角线的两个点;然后输出其两个矩形相交叉的面积;

思路:这个题一开始看起来很麻烦,但当画出图来的时候就会发现,只要让横坐标的第三大的数减去第二大的数在乘上纵坐标的第三大的数减去第二大的数(即(x[3]-x[2])*(y[3]-y[2])),即是交叉的面积;不过要特别注意的一点就是要提前判断上两个矩形是否 有交叉,有交叉才能这样计算的!!

反思点:一开始对于没有交叉的情况忘记考虑,所以说明自己在思考问题的时候还是不够全面,以后在做题的时候把一些特殊情况,即只要题目中未说不会这样发生,就去考虑一下这种特殊情况的处理方式!!;

新技巧:这个题目一开始以为会很多情况,不过后来发现有规律可寻,所以在一些计算题的时候,一般都会有一定得规律可寻,不会让你傻傻的把所以情况全列出来,然后计算的!!;

代码:

#include<iostream>
#include<cstring>
#include<iomanip>

using namespace std;
int main()
{
    int t,i,j,m,n;
    double x[4],y[4],ss,sum;
    while(cin >> x[0]){
        int tag=1;
        cin >> y[0];
        for(i=1;i<4;++i){
            cin >> x[i] >> y[i];
        }
        if((x[0]>x[3]&&x[0]>x[2]&&x[1]>x[3]&&x[1]>x[2])||(x[0]<x[3]&&x[0]<x[2]&&x[1]<x[3]&&x[1]<x[2])||(y[0]>y[3]&&y[0]>y[2]&&y[1]>y[3]&&y[1]>y[2])||(y[0]<y[3]&&y[0]<y[2]&&y[1]<y[3]&&y[1]<y[2]))
           tag=0;
        if(tag)
        {
            for(i=1;i<4;++i){
                for(j=0;j<4-i;++j){
                    if(x[j]>x[j+1]){
                        ss=x[j];x[j]=x[j+1];x[j+1]=ss;
                    }
                    if(y[j]>y[j+1]){
                        ss=y[j];y[j]=y[j+1];y[j+1]=ss;
                    }
                }
            }
            sum=(x[2]-x[1])*(y[2]-y[1]);
        }
        else sum=0;
        cout << fixed;
        cout.precision(2);
        cout << sum << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值