Assistance Required(打表)

Assistance Required

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 719    Accepted Submission(s): 384


Problem Description
After the 1997/1998 Southwestern European Regional Contest (which was held in Ulm) a large contest party took place. The organization team invented a special mode of choosing those participants that were to assist with washing the dirty dishes. The contestants would line up in a queue, one behind the other. Each contestant got a number starting with 2 for the first one, 3 for the second one, 4 for the third one, and so on, consecutively. 
The first contestant in the queue was asked for his number (which was 2). He was freed from the washing up and could party on, but every second contestant behind him had to go to the kitchen (those with numbers 4, 6, 8, etc). Then the next contestant in the remaining queue had to tell his number. He answered 3 and was freed from assisting, but every third contestant behind him was to help (those with numbers 9, 15, 21, etc). The next in the remaining queue had number 5 and was free, but every fifth contestant behind him was selected (those with numbers 19, 35, 49, etc). The next had number 7 and was free, but every seventh behind him had to assist, and so on. 

Let us call the number of a contestant who does not need to assist with washing up a lucky number. Continuing the selection scheme, the lucky numbers are the ordered sequence 2, 3, 5, 7, 11, 13, 17, etc. Find out the lucky numbers to be prepared for the next contest party. 
 

Input
The input contains several test cases. Each test case consists of an integer n. You may assume that 1 <= n <= 3000. A zero follows the input for the last test case. 
 

Output
For each test case specified by n output on a single line the n-th lucky number. 
 

Sample Input
 
  
1 2 10 20 0
 

Sample Output
 
  
2 3 29 83
 

Source
 

Recommend
Eddy
 

打表即可 ,很多网友说用链表模拟,我是直接用数组,效率也不低,140MS。

用一个数组ans储存3000个幸免参赛者的编号,设置布尔型数组que用以标记队伍中的哪些参赛者已经被征役去打杂,que[i] == false表明编号为i(注意第一个人的编号是2)的参赛者还未被征役,否则表明已经被选去洗碟子。

AC CODE

#include <iostream>
#include <cstdio>
using namespace std;

int ans[3001] = {0};
bool que[40010] = {1, 1, 0};

int main()
{
    int k, i, j, cnt;
    for(k = 0; k < 3001; k++)
    {
        //这个for loop找到下一个未被选中的人
        for(i = ans[k-1]+1; que[i]; i++){}
        ans[k] = i;
        for(j = i+1, cnt = i; j < 40010; j++)
        {
            if(!que[j] && !--cnt)
            {
                que[j] = 1;
                cnt = i;
            }
        }
    }
   // for(i = 1; i < 20; i++) cout<< ans[i] << " ";
   // cout<<endl;
    while(scanf("%d", &i) && i)
    {
        printf("%d\n", ans[i-1]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值