[结题报告]686 - Goldbach's Conjecture (II) Time limit: 3.000 seconds


  Goldbach's Conjecture (II) 

Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.

 


This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

 


A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1p2) and (p2p1) separately as two different pairs.

 

Input 

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 215. The end of the input is indicated by a number 0.

 

Output 

Each output line should contain an integer number. No other characters should appear in the output.

 

Sample Input 

 

6
10
12
0

 

Sample Output 

1
2
1

参考代码:
任何一个比4大的偶数一定能够找到2个质数使其和相等。例如: 8=3+5(3和5都是奇数,且是质数) 20=3+17=7+13 42=5+37=11+31=13+29=19+23 你的任务就是写一个程式输出对每一个大于4的偶数,可以找到几组这样的奇数质数的组合。我的思路是,依次求出N的因子,然后判断因子是否为质数,因为因子总是两两配对,所以我干脆就算全算,最后除2就行.请注意:我们只对有几组不同的组合有兴趣,所以(p1,p2)和(p2,p1)不应该被视为不同的组合。其中有几点要注意一下,比如9(3,3)这样的组合要注意一下。
#include"stdio.h"
#include"math.h"
int fun(int n)   //判断是否为质数 
{ int t,m;
  m=(int)sqrt(n);
  for(t=2;t<=m;t++)
   if(n%t==0)
   return 0;
  return 1;  
    }
int main(void)
{ int n,m,i,flag1,flag2,count;
  while(scanf("%d",&n)&&n)
  { count=0;
    for(i=2;i<=n-2;i++)
    {m=n-i;
     flag1=fun(i);
     flag2=fun(m);
     if(flag1&&flag2)
      {count++;
       if(i==m)     //因为输出时/2,所以当3数相等时,当2组算 
       count++;}
       }
     printf("%d\n",count/2); 
                           }return 0;
      }

 

 

转载于:https://www.cnblogs.com/sjy123/archive/2013/02/23/2923263.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值