Periodic Strings(周期串)

A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string "abcabcabcabc" has period 3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").

 

Write a program to read a character string and determine its smallest period.

 

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

 

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

 

Sample Input

 

1

HoHoHo

Sample Output

2
如果一个字符串可以由某个长度为k的字符串重复多次得到,则称该串以k为周期。例如,abcabcabc以3为周期(注意,它也以6和9为周期)
输入一个长度不超过80的字符串,输出其最小周期。

#include<stdio.h>
#include<string.h>
char s[100];
int main()
{
    int t,ok;
    scanf("%d",&t);    
    while(t--){
        scanf("%s",s);
        int n=strlen(s);
        for(int i=1;i<=n;i++){ //周期
            if(n%i==0){  //周期必须能够整除字符串长度,如ababab的周期为2,字符串长度为6,6%2=0,或者abcd的周期为4,字符串长度为4,4%4=0;
                ok=true;
                for(int j=i;j<n;j++){
                if(s[j]!=s[j%i]){ //根据周期比较字符串
                 ok=false; 
                 break;
                }
            }
            if(ok){
                printf("%d\n",i);
                break;
               }
            }
        }
        if(t!=0)
            printf("\n");
    }
    return 0;
}

 
































 

转载于:https://www.cnblogs.com/bearkid/p/7290896.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值