Uva 455 Periodic Strings

 

A character string is said to have period k if it can be formed by concatenating one or more repetitions

of another string of length k. For example, the string ”abcabcabcabc” has period 3, since it is formed
by 4 repetitions of the string ”abc”. It also has periods 6 (two repetitions of ”abcabc”) and 12 (one
repetition of ”abcabcabcabc”).

Write a program to read a character string and determine its smallest period.


Input
The first line oif the input file will contain a single integer N indicating how many test case that your
program will test followed by a blank line. Each test case will contain a single character string of up

to 80 non-blank characters. Two consecutive input will separated by a blank line.


Output
An integer denoting the smallest period of the input string for each input. Two consecutive output are

separated by a blank line.


Sample Input
1
HoHoHo
Sample Output

2


AC代码:

#include<cstdio>
#include<cstring>

char str[1111];
int ne[1111];

void Get_ne(char *str,int len)
{
	int i=0,j=-1; ne[0]=-1;
	while(i<len) {
		if(j==-1||str[i]==str[j]) ne[++i]=++j;
		else j=ne[j];
	}
}
int main()
{
    int T;
	scanf("%d",&T);
	while(T--) 
	{
		scanf("%s",str);
		int len=strlen(str);
		Get_ne(str,len);
		printf("%d\n",len%(len-ne[len])==0?(len-ne[len]):len);
	    if(T) putchar('\n');  
    }     
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值