HDOJ 2802 F(N)

Problem Description

Giving the N, can you tell me the answer of F(N)?

Input
Each test case contains a single integer N(1<=N<=10^9). The input is terminated by a set starting with N = 0. This set should not be processed.

Output
For each test case, output on a line the value of the F(N)%2009.

Sample Input
1
2
3
0

Sample Output
1
7
20

一般这种让根据公式求出对应项的值得题都有规律 (有一个循环,此题的循环为4018(注意 这种有循环规律的是让你输出对应项对某个数取余后的题))可以先打表写出有限个数的结果,再观察规律,或者直接写代码判断是否进入了循环。

import java.math.BigDecimal;
import java.util.Scanner;

public class Main {
    static int[] f = new int[10000];
    public static void main(String[] args) {
        f[1]=1;
        f[2]=7;
        for(int i=3;i<=4018;i++){
            f[i] = (f[i-2]-((i-1)*(i-1)*(i-1))+(i*i*i))%2009;
            //System.out.println(i+" "+f[i]);
        }
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n = sc.nextInt();
            if(n==0)
                return ;
//          for(int i=3;i<100000;i+=2){
//              if(f[i]==1&&f[i+1]==7){
//                  System.out.println(i-1);
//                  break;
//              }
//          }
            //判断多久开始循环
            System.out.println(f[n%4018]);
        }

    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值