[结题报告]11364 - Parking Time limit: 1.000 seconds


  C: Optimal Parking 

When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs. Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round?

 

\epsfbox{p11364.eps}<tex2html_verbatim_mark>

Long Street is a straight line, where all positions are integer. You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.

 

Input 

The first line of input gives the number of test cases, 1$ \le$t$ \le$100 <tex2html_verbatim_mark>. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1$ \le$n$ \le$20 <tex2html_verbatim_mark>, and the second gives their n <tex2html_verbatim_mark>integer positions on Long Street, 0$ \le$xi$ \le$99 <tex2html_verbatim_mark>.

 

Output 

Output for each test case a line with the minimal distance Michael must walk given optimal parking.

 

Sample Input 

 

2 
4 
24 13 89 37 
6 
7 30 41 14 39 42

 

Sample Output 

 

152
70

 参考代码:

题目大意讲一个人车停在什么地方去逛街的路程最短,其实在店按高低排好,其路程都是(最大路程-最小路程)*2。首先,冒泡讲若干数进行排序,排序完成后,第一个数和最后一个数分别代表最大数和最小数,(当然,如果觉得排序麻烦,也可以先定义个min,max,然后各个数进行比较求出最大和最小).然后就可以求出这个人要走的路程了.

#include"stdio.h"
int main(void)
{
    int t,n,i,j,swap,temp;
    int a[20];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        scanf("%d",&a[i]);
        for(i=0;i<n-1;i++)           //冒泡排序       
        {
            swap=0;
            for(j=0;j<n-i-1;j++)         
            if(a[j]<a[j+1])
            {
                swap=1;
                temp=a[j+1];
                a[j+1]=a[j];
                a[j]=temp;
            }
            if(!swap)break;
           }
        printf("%d\n",(a[0]-a[n-1])*2);

    }
    return 0;
}

 

转载于:https://www.cnblogs.com/sjy123/archive/2013/02/23/2923601.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值