poj 3959 Alignment of Code <vector>“字符串”

Description

You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other tabular information and aligns each column on a fixed vertical position, while keeping the resulting code as short as possible, making sure that only whitespaces that are absolutely required stay in the code. So, that the first words on each line are printed at position p 1 = 1; the second words on each line are printed at the minimal possible position p 2, such that all first words end at or before position p 2 - 2; the third words on each line are printed at the minimal possible position p 3, such that all second words end at or before position p 3 - 2, etc. For the purpose of this problem, the code consists of multiple lines. Each line consists of one or more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all ASCII punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to 126 inclusive). Whitespace consists of space characters (ASCII code 32).

Input

The input file contains one or more lines of the code up to the end of file. All lines (including the last one) are terminated by a standard end-of-line sequence in the file. Each line contains at least one word, each word is 1 to 80 characters long (inclusive). Words are separated by one or more spaces. Lines of the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters long. There are at most 1000 lines in the input file.

Output

Write to the output file the reformatted, aligned code that consists of the same number of lines, with the same words in the same order, without trailing and leading spaces, separated by one or more spaces such that i-th word on each line starts at the same position p i.

Sample Input

  start:  integer;    // begins here
stop: integer; //  ends here  
 s:  string;   
c:   char; // temp 

Sample Output

start: integer; // begins here
stop:  integer; // ends   here
s:     string;
c:     char;    // temp


代码超时!!!!!!!!!!!!!!!
#include <iostream>
#include <cstdio>
#include <string>
#include <vector>
#include <sstream>
using namespace std;

vector<string> code[1000];      //1000行单词
int len[110];
int main()
{ 
    int n = 0;                            //len中存储一行中每个单词的长度
    string line;
    while((getline(cin,line)) != NULL){

        n++;
        stringstream ss(line);                //不用这个会累死的

        int q = 0;                            //q为每行单词第几个数
        string word;
        while(ss >> word){
            int t = word.length();
            if(n == 1)len[q] = t;
            else if(len[q] < t)len[q] = t;          //同一列单词中最长的
            q++;
            code[n].push_back(word);
        }
    } 

    for(int i = 0;i <= n;i++){

        int N = code[i].size();
        
        for(int j = 0;j < N;j++){

            line = code[i][j];
            int q = line.length();
            cout << code[i][j];

            for( int p = 0;p <= len[j] - q;p++)printf(" ");
        }
        putchar('\n');
    }

   // system("pause");
    return 0;
}


n++的位置不对 导致插入向量的字符串存在问题

#include <iostream>
#include <cstdio>
#include <string>
#include <vector>
#include <sstream>
using namespace std;

vector<string> code[1000];      //1000行单词
int len[110];
int main()
{ 
    int n = 0;                            //len中存储一行中每个单词的长度
    string line;
    while((getline(cin,line)) != NULL){
        stringstream ss(line);                //不用这个会累死的
        
        int q = 0;                            //q为每行单词第几个数
        string word;
        while(ss >> word){
            int t = word.length();
            if(n == 0)len[q] = t;
            else if(len[q] < t)len[q] = t;         //同一列单词中最长的
            q++;
            code[n].push_back(word);
        }
        n++;
    } 
    for(int i = 0;i < n;i++){

        int N = code[i].size();
        
        for(int j = 0;j < N;j++){

            line = code[i][j];
            int q = line.length();
            cout << code[i][j];

            for( int p = 0;p <= len[j] - q;p++)printf(" ");
        }
        putchar('\n');
    }

   // system("pause");
    return 0;
}

 

补充几点

在vector中查找特定的元素

用 find 函数,头文件#include <algorithm>

vector<int> x;
 x.push_back(123);
 x.push_back(333);
 x.push_back(222);
 vector<int>::iterator iter;
 iter = find(x.begin(), x.end(), 222);

 

清空vector

vector<int>student;
student.clear();

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值