uva- 1593 - Alignment of Code c++,stl练习

题目点我


1593 - Alignment of Code

Time limit: 3.000 seconds


You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other tabular information and aligns each column on a fixed vertical position, while keeping the resulting code as short as possible, making sure that only whitespaces that are absolutely required stay in the code. So, that the first words on each line are printed at position p1 = 1; the second words on each line are printed at the minimal possible position p2, such that all first words end at or before position p2 - 2; the third words on each line are printed at the minimal possible position p3, such that all second words end at or before position p3 - 2, etc.

For the purpose of this problem, the code consists of multiple lines. Each line consists of one or more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all ASCII punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to 126 inclusive). Whitespace consists of space characters (ASCII code 32).

Input 

The input file contains one or more lines of the code up to the end of file. All lines (including the last one) are terminated by a standard end-of-line sequence in the file. Each line contains at least one word, each word is 1 to 80 characters long (inclusive). Words are separated by one or more spaces. Lines of the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters long. There are at most 1000 lines in the input file.

Output 

Write to the output file the reformatted, aligned code that consists of the same number of lines, with the same words in the same order, without trailing and leading spaces, separated by one or more spaces such that i-th word on each line starts at the same position pi.


Note for the Sample:

The `$ \sqcup$' character in the example below denotes a space character in the actual files (ASCII code 32).

Sample Input 

  start:  integer;    // begins here
stop: integer; //  ends here  
 s:  string;   
c:   char; // temp

Sample Output 

start: integer; // begins here 
stop:  integer; // ends   here 
s:     string;
c:     char;    // temp
 
 
 
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<string.h>
#include<vector>
#include<sstream>

const int maxn=1000+7;


using namespace std;


vector<string> code[maxn];

//int cnt;
int row, column;
int maxlen[200];
void input_line(string & line)
{

    //cnt=0;
    int t=0;
    stringstream ss(line);
    string x;
    while(ss>>x){
        code[row].push_back(x);
        t++;
    }
    column=max(column, t);
    row++;
}

void cmpa(int r)
{

    for(int i=0;i<row;i++){
        int siz= code[i].size();




        if(siz>=r+1){
            int len = code[i][r].length();
            maxlen[r]=max(maxlen[r], len);
        }
    }
}

int main()
{
    string line;

    while(getline(cin, line)){
        if(line==" ") continue;
        //row++;
        input_line(line);

    }

    for(int i=0;i<column;i++){

        cmpa(i);
    }

    for(int i=0;i<row;i++){
        int len=code[i].size();
        for(int j=0;j<len-1;j++){

            cout<<code[i][j];

            for(int k=0;k< maxlen[j]+1-(int)code[i][j].length();k++){
                cout<<" ";
            }

        }
        cout<<code[i][len-1]<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Sure! Here's an example of a 4-lane MIPI data alignment module written in Verilog: ```verilog module mipi_data_alignment ( input [31:0] data_in, input clk, input rst, output reg [31:0] data_out ); reg [31:0] shift_reg [0:3]; always @(posedge clk or posedge rst) begin if (rst) begin for (int i = 0; i < 4; i = i + 1) begin shift_reg[i] <= 32'b0; end end else begin for (int i = 0; i < 4; i = i + 1) begin shift_reg[i] <= {shift_reg[i][30:0], data_in[i*8 +: 8]}; end end end always @(posedge clk) begin if (rst) begin data_out <= 32'b0; end else begin for (int i = 0; i < 4; i = i + 1) begin data_out[i*8 +: 8] <= shift_reg[i][31:24]; end end end endmodule ``` In this module, `data_in` is a 32-bit input representing the MIPI data for the four lanes, `clk` is the clock signal, `rst` is the reset signal, and `data_out` is the aligned output data for the four lanes. The array `shift_reg[0:3]` consists of four 32-bit shift registers, each corresponding to one lane. On each rising edge of the clock (`clk`), the data for each lane is shifted left by eight bits, and the new input data for each lane is concatenated to the rightmost eight bits of the corresponding shift register. This aligns the incoming MIPI data stream for each lane. The aligned output data for each lane is updated on each rising edge of the clock based on the current values of the shift registers. Remember to customize this code according to your specific requirements and the MIPI protocol specifications you are working with.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值