hdu 5587 Array 数学题

Array

Time Limit: 20 Sec

Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5587

Description

Vicky is a magician who loves math. She has great power in copying and creating.
One day she gets an array {1}。 After that, every day she copies all the numbers in the arrays she has, and puts them into the tail of the array, with a signle '0' to separat.
Vicky wants to make difference. So every number which is made today (include the 0) will be plused by one.
Vicky wonders after 100 days, what is the sum of the first M numbers.

Input

There are multiple test cases.
First line contains a single integer T, means the number of test cases.(1T2103)
Next T line contains, each line contains one interger M. (1M1016)

Output

For each test case,output the answer in a line.

Sample Input

3 1 3 5

Sample Output

1 4 7

HINT

 

题意

题解:

数学题(:

首先我们先用找规律算出第i天一共能得到的和是多少:g(i)=g(i-1)+2^(i-1)

然后我们就可以递归求解了,不断地利用2的幂来进行递归

代码:

#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<cstring>
using namespace std;

vector<long long>Q;
long long ans = 0;
long long g[230];
void solve(long long k)
{
    if(k<=0)return;
    int p = --upper_bound(Q.begin(),Q.end(),k)-Q.begin();
    ans+=g[p]+k-Q[p];
    solve(k-Q[p]-1);
}
int main()
{

    long long T=2;
    Q.push_back(0);
    for(int i=1;i<=59;i++)
    {
        Q.push_back(T-1);//2^i-1
        T*=2;
    }
    g[1]=1;long long tmp=2;
    for(int i=2;i<=Q.size();i++)
    {
        g[i]=2*g[i-1]+tmp;//存的是第i天的答案
        tmp=tmp*2;
    }
    int t;scanf("%d",&t);
    for(int i=1;i<=t;i++)
    {
        long long x;scanf("%I64d",&x);
        ans = 0;
        solve(x);
        printf("%I64d\n",ans);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值