1032. Sharing (25)

题目链接:http://www.patest.cn/contests/pat-a-practise/1032

题目:

1032. Sharing (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.


Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, andNext is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1

分析:

两个链表。找到它们相交的第一个节点。

注意:

可能存在多个字串。而且可能有其它非题目中两字串的节点存在。而且注意最后是要输出%05d的

AC代码:

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int nodes[100001];
int real_nodes[100001];
int main(void){
 //freopen("F://Temp/input.txt", "r", stdin);
 int s1, s2, n;
 scanf("%d %d %d", &s1, &s2, &n);
 int s, t;
 char c;
 for (int i = 0; i < 100001; i++){
  nodes[i] = 0;
  real_nodes[i] = 0;
 }
 for (int i = 0; i < n; i++){
  scanf("%d %c %d", &s, &c, &t);
  nodes[s] = t;
 }
 int start = s1; int end;
 while (start != -1){
  real_nodes[start] = 1;
  start = nodes[start];
 }//找到第一个链表的全部节点,并置为1
 start = s2;
 bool find = false;
 while (start != -1){
  if (real_nodes[start] != 0){//假设第二个链表中地址已经有记录,则就是第一个公共节点
   printf("%.5d\n", start);
   return 0;
  }
  else {
   real_nodes[start] = nodes[start];
   start = nodes[start];
  }
 }
 puts("-1");
 return 0;
}


截图:


——Apie陈小旭

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值