1032 Sharing (25分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

在这里插入图片描述

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

思路:

一开始想投机取巧来着,既然要找两个链表的公共部分,那么直接读入的时候看哪个结点被指向两次,这个结点就是公共部分了嘛。

错误示范

#include<bits/stdc++.h>
using namespace std;
set<int> st;//集合存储结点,一旦有一个节点读入之前在集合中查到,那么说明这个结点就是公共链表开头
int main() {
    int a, b, n;
    cin >> a >> b >> n;
    int ini;
    for (int i = 0; i < n; i++) {
        int t, ans;
        char c;
        scanf("%d %c %d", &t, &c, &ans);
        if (st.count(ans)) {
            ini = ans;
            break;
        } else
            st.insert(ans);
    }
    if (ini != -1)
        printf("%05d", ini);
    else
        cout << ini;
}

在这里插入图片描述
果然是我太菜了吗。。。后来参照了柳婼的博客:柳婼大佬
妙!
改正:

#include<bits/stdc++.h>
#define Max 100000
using namespace std;
struct node{
    int flag,next;
    char data;
}t[Max];
int main()
{
    int a,b,n;
    cin>>a>>b>>n;
    for(int i=0;i<n;i++){
        int tail,id;
        char data;
        scanf("%d %c %d",&id,&data,&tail);
        t[id]={0,tail,data};
    }
    while(a!=-1){
        t[a].flag=1;
        a=t[a].next;
    }
    while(b!=-1){
        if(t[b].flag){
            printf("%05d",b);
            return 0;
        }
        b=t[b].next;
    }
    cout<<-1;
}

emmm,可是我前面那种方法貌似没啥毛病啊。。。不知道有没有感兴趣的朋友指点一下。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值