PAT 1039 Course List for Student[难]

1039 Course List for Student (25 分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (40,000), the number of students who look for their course lists, and K (2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni​​ (200) are given in a line. Then in the next line, Ni​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

 题目大意:给出查询课程的学生总数,以及课程总数。下面的格式是课程id,课程总人数,以及参课学生名。最后给出查询课程的学生,要求输出每个学生选课的课表。

//本来我是打算这么写的,但是后来一看数据量,复杂度可能到千万级别,那大数测试肯定是过不去了。

#include <iostream>
#include <algorithm>
#include<cstdio>
#include<stdio.h>
#include <map>
#include<cmath>
#include <set>
using namespace std;
struct Cou{
    set<string> st;
}cou[2510];

int main()
{
    int n,m;
    cin>>n>>m;
    int id,num;
    string stu;
    for(int i=0;i<m;i++){
        cin>>id>>num;
        for(int j=0;j<num;j++){
            cin>>stu;
            cou[j].st.insert(stu);
        }
    }
    for(int i=0;i<n;i++){
        cin>>stu;        
    }
    
    return 0;
}

 

//然后写了这个版本,但是最后一个测试用例过不去,显示段错误,将数组长度改为40010还是不行,遂放弃。

#include <iostream>
#include <algorithm>
#include<cstdio>
#include<stdio.h>
#include <map>
#include<cmath>
#include <vector>
using namespace std;
vector<int> vt[40010];
map<string,int> mp;

int main()
{
    int n,m;
    cin>>n>>m;
    int id,num,ct=0,sid;//统计总共有多少个学生。
    string stu;
    for(int i=0; i<m; i++)
    {
        cin>>id>>num;
        for(int j=0; j<num; j++)
        {
            cin>>stu;
            if(mp.count(stu)==0)
            {
                mp[stu]=ct++;
            }
            sid=mp[stu];
            vt[sid].push_back(id);//这个id还要按升序排列我的天。
        }
    }
    for(int i=0;i<40010;i++){
        if(vt[i].size()!=0){
            sort(vt[i].begin(),vt[i].end());
        }
    }
    for(int i=0; i<n; i++)
    {
        cin>>stu;
        if(mp.count(stu)==0){
            cout<<stu<<" 0";
        }else{
            sid=mp[stu];
            cout<<stu<<" "<<vt[sid].size();
            for(int j=0;j<vt[sid].size();j++){
                cout<<" "<<vt[sid][j];
            }
        }
        if(i!=n-1)cout<<'\n';
    }

    return 0;
}

 

之后百度发现是不可使用string类型,都是将名字转换为ASCII。

//我又想到将转化为scanf,但是似乎它是不能读入string类型的。又将其改成了这样:

#include <iostream>
#include <algorithm>
#include<cstdio>
#include<stdio.h>
#include <map>
#include<cmath>
#include <vector>
using namespace std;
vector<int> vt[40010];
map<string,int> mp;

int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    int id,num,ct=0,sid;//统计总共有多少个学生。
    string stu;
    stu.resize(8);
    for(int i=0; i<m; i++)
    {
        scanf("%d%d",&id,&num);
        for(int j=0; j<num; j++)
        {
            scanf("%s",&stu[0]);
            if(mp.count(stu)==0)
            {
                mp[stu]=ct++;
            }
            sid=mp[stu];
            vt[sid].push_back(id);//这个id还要按升序排列我的天。
        }
    }
    for(int i=0;i<40010;i++){
        if(vt[i].size()!=0){
            sort(vt[i].begin(),vt[i].end());
        }
    }
    for(int i=0; i<n; i++)
    {
        scanf("%s",&stu[0]);
        if(mp.count(stu)==0){
            printf("%s 0",stu.c_str());
           //cout<<stu<<" 0";
        }else{
            sid=mp[stu];
            printf("%s %d",stu.c_str(),vt[sid].size());
            //cout<<stu<<" "<<vt[sid].size();
            for(int j=0;j<vt[sid].size();j++){
                printf(" %d",vt[sid][j]);
                //cout<<" "<<vt[sid][j];
            }
        }
        if(i!=n-1)printf("\n");
    }

    return 0;
}

 

依旧是段错误,所以还是改吧。

1.学习了如何使用scanf读入string类型,预先分配空间。:https://blog.csdn.net/sugarbliss/article/details/80177377

下面是柳神的代码:

高亮区域实在是厉害。

1.使用char数组存储,并不使用map,对于这个名字id转化的函数;

2.使用scanf和printf输入输出。

转载于:https://www.cnblogs.com/BlueBlueSea/p/9939503.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值