HDU 5175 Misaki's Kiss again

Misaki's Kiss again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 513    Accepted Submission(s): 121


Problem Description
After the Ferries Wheel, many friends hope to receive the Misaki's kiss again,so Misaki numbers them 1 , 2 , .... , N , if someone number is M and satisfied the  GCD(N,M) equal to N XOR M , he will be kissed again .
 
Please help Misaki to find all M ( 1 <= M <= N ) .
 
Node that :
GCD( a , b ) means the greatest common divisor of a and b .
A XOR B means A exclusive or B
 
Input
There are multiple test cases.

For each testcase, contains a integets N(0<N<=1010)
 

 

Output
For each test case,
first line output Case #X:,
second line output k means the number of friends will get a kiss.
third line contains k number mean the friends' number, sort them in ascending and separated by a space between two numbers
 

 

Sample Input
3
5
15
 

 

Sample Output
Case #1:
1
2
Case #2:
1
4
Case #3:
3
10 12 14
Hint
In the third sample, gcd(15,10)=5 and (15 xor 10)=5, gcd(15,12)=3 and (15 xor 12)=3,gcd(15,14)=1 and (15 xor 14)=1

 

sqrt(n) 求出n的所有约数ei。

然后求出 a 符合: a^n == ei  。

再判断 a 跟 n 的 GCD 是否等于ei 即可。

 

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <vector>
#include <map>
#include <vector>
#include <queue>

using namespace std ;
typedef long long LL ;
typedef pair<int,int> pii;
#define X first
#define Y second

const int N = 100010;
LL n , e[N] , x[N] ;
int aa[100] , bb[100] , res[100] ;
inline LL gcd( LL a , LL b ) { return b == 0 ? a : gcd( b , a % b );}
LL decode( LL a , LL b ) {
    int lena = 0 , lenb = 0 ;
    memset( aa , 0 , sizeof aa );
    memset( bb , 0 , sizeof bb );
    LL x = a ;
    while( x > 0 ) { aa[lena++] = x % 2 ; x /= 2 ; }
    x = b ;
    while( x > 0 ) { bb[lenb++] = x % 2 ; x /= 2 ; }

    LL ans = 0 ;
    for( int i = 0 ; i < lena ; ++i ) {
        if( bb[i] == 0 ) res[i] = aa[i];
        else res[i] = aa[i]^1;
        if( res[i] ) ans += (1LL<<i);
    }
    return ans ;
}

void solve() {
    int tot = 0 , cnt = 0  ;
    for( LL i = 1 ; i * i <= n ; ++i ) {
        if( n % i == 0 ){
            e[tot++] = i ;
            if( i != n/i ) e[tot++] = n/i ;
        }
    }
    for( int i = 0 ; i < tot ; ++i ) {
       LL tmp = decode( n , e[i] );
       if( tmp < 1 || tmp > n || tmp < e[i] || gcd( n , tmp ) != e[i] ) continue ;
       x[cnt++] = tmp ;
    }
    sort( x , x + cnt );
    printf("%d\n",cnt);
    for( int i = 0 ; i < cnt ; ++i ) {
        printf("%I64d",x[i]);
        if( i < cnt -1 ) printf(" ");
    }
    puts("");
}
int main ()  {
    #ifdef LOCAL
        freopen("in.txt","r",stdin);
    #endif // LOCAL
    int _ , cas =1 ;
    while( scanf("%I64d",&n) != EOF ) {
        printf("Case #%d:\n",cas++);
        solve();
    }
}
View Code

 

转载于:https://www.cnblogs.com/hlmark/p/4292843.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值