[WUST2017]一组简单一点的题目(一)W - Digital Roots

题目:W - Digital Roots
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output
For each integer in the input, output its digital root on a separate line of the output.
Sample Input
24
39
0
Sample Output
6
3

大意:就是输入一个数,将其每一位上的数都取出来相加,看能否出现满足这个数是个位数;

思路:因为这个题为表明其范围,所以有可能位数非常多,即数非常大;则不能通过一个一个取位的方法来进行;则这时候要通过字符串取,并且每次相加的时候,如果这个数变成两位数了(即大于9了),则立马将其分解成个位数,进而相加,这样就不用再等全加完在继续了。这里提前分解相加和全相加之后分解本质上是一样的,因为就像10+6=16,前面先分开则为1+0+6,后面则为1+6,所以一样的;

小技巧:对于这类数的问题,为表明范围的时候要特意考虑一下有没有可能出现非常大的数或者非常小的数之类的,还有对于每个位相加的问题,即10+6=16,前面先分开则为1+0+6,后面则为1+6,所以一样的
,这种出现不能用常规方式处理的数时,就很有可能用一些小技巧,其满足什么条件之后接着进行分解之类的。小技巧的利用非常重要,自己要加油体会到;

代码:

#include<stdio.h>
#include<string.h>
char s[1000000];
int main()
{
    int n,sum;

    while(scanf("%s",s)!=EOF)
    {
        if(strcmp(s,"0")==0)
            break;
        n=strlen(s);
        sum=0;
        for(int i=0;i<n;i++)
        {
            sum+=s[i]-'0';
            if(sum>=10)
                sum=sum%10+sum/10;
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值