[POJ] 1002 487-3279

487-3279

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 320280Accepted: 56657

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.


The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:
No duplicates.

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

解题思路

本题通过率较低,导致Wrong Answer的原因可能包括:

*C++中的cin、cout相较于C中的scanf、printf而言较慢,而本题的输入数据量较大,容易导致超时。

*没有对Q、Z进行处理。

*G++编译环境下WA的代码,在C++编辑环境下可能AC,这是一个玄学。

解题关键点如下:

1、将电话号码以字符串形式输入,对电话号码中的“Q”、“Z”、“-”进行过滤,并根据字母的映射规律将电话号码转化为数字形式存储在动态数组中。

2、对动态数组进行排序,方便统计电话号码出现的次数及字典序输出。

3、以题目规定的标准形式输出重复的电话号码及其出现的次数,需要注意电话号码输出时的处理,否则容易导致WA,例如电话号码“001-0000”被错误输出为“1-0”。

代码注释较为详细,C++下已AC。将代码中的cin和cout改进为scanf和cout应该可进一步降低代码运行时间,各位有兴趣的话可以试试。

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <iomanip>
using namespace std;
vector<int> ans;//用于保存电话号码
int main()
{
    int n,flag=0;
    cin>>n;
    for(int i=0;i<n;i++){
        string s="";
        cin>>s;
        int sum=0;//将电话号码保存为数字,如TUT-GLOP转化为8884567
        for(int j=0;j<s.length();j++){
            if(s[j]=='-'||s[j]=='Q'||s[j]=='Z') continue;//Q、Z、-没有映射
            else{
                if('0'<=s[j]&&s[j]<='9')//数字映射
                    sum=sum*10+s[j]-'0';
                else if('A'<=s[j]&&s[j]<='P')//总结字母映射规律,简化代码
                    sum=sum*10+(s[j]-'A')/3+2;
                else if('R'<=s[j]&&s[j]<='Y')
                    sum=sum*10+(s[j]-'A'-1)/3+2;
            }
        }
        ans.push_back(sum);
    }
    sort(ans.begin(),ans.end());//对电话号码进行排序,以便字典升序输出
    for(int i=0,temp=ans[0],num=0;i<=ans.size();i++){
        if((ans[i]!=temp||i==ans.size())&&num>1){//存在重复号码时输出
            flag=1;
            cout<<setfill('0')<<setw(3)<<temp/10000;
            cout<<"-";
            cout<<setfill('0')<<setw(4)<<temp%10000;
            cout<<" "<<num<<endl;
            if(i==ans.size()) break;//防止vector越界
            temp=ans[i];num=1;
        }
        else if(ans[i]!=temp&&num==1)
            temp=ans[i];
        else
            num++;
    }
    if(!flag)
        cout<<"No duplicates."<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值