poj2299

Ultra-QuickSort

Time Limit: 7000MSMemory Limit: 65536K
Total Submissions: 20073Accepted: 7102

Description


In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

 

#include <iostream>

using namespace std;

const int SORT_NUM = 500000;
const int MAX_NUM=999999999;
long long reverse_num;

void merge(int* a, int p, int r, int q)
{
    int L[r-p+1], R[q-r];
    int ln, rn, an;

    for(int i=0; i<=r-p; i++)
    {
        L[i]=a[p+i];
    }
    for(int j=0; j<=q-r-1; j++)
    {
        R[j]=a[j+r+1];
    }

    ln=0;
    rn=0;
    an=p;
    while(ln<=r-p && rn<=q-r-1)
    {
        if(L[ln]<=R[rn])
        {
            a[an]=L[ln];
            an++;
            ln++;
        }
        else
        {
            a[an]=R[rn];
            an++;
            rn++;
            reverse_num += (r-p-ln+1);
        }
    }
    while(ln<=r-p)
    {
        a[an]=L[ln];
        an++;
        ln++;
    }
    while(rn<=q-r-1)
    {
        a[an]=R[rn];
        an++;
        rn++;
    }
}

void merge_sort(int* a, int p, int q)
{
    int r;

    if(p<q)
    {
        r=(p+q)/2;
        merge_sort(a,p,r);
        merge_sort(a,r+1,q);
        merge(a,p,r,q);
    }

}

int main()
{
    int a[SORT_NUM];
    int n;

    cin>>n;
    while(n!=0)
    {
        reverse_num=0;
        for(int i=0; i<n; i++)
        {
            cin>>a[i];
        }
        merge_sort(a,0,n-1);
        cout<<reverse_num<<endl;
        cin>>n;
    }
    return 0;
}

转载于:https://www.cnblogs.com/eric-blog/archive/2011/04/18/2019970.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值