POJ 2299(树状数组求逆序对)

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 – the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5
9
1
0
5
4
3
1
2
3
0
Sample Output
6
0

#include<bits/stdc++.h>
#define fi first
#define se second
#define FOR(a) for(int i=0;i<a;i++)
#define show(a) cout<<a<<endl;
#define show2(a,b) cout<<a<<" "<<b<<endl;
#define show3(a,b,c) cout<<a<<" "<<b<<" "<<c<<endl;
using namespace std;

typedef long long ll;
typedef pair<int,int> P;
typedef pair<P,int> LP;
const ll inf=0x3f3f3f3f;
const int N=1e6+10;
const ll mod=998244353;

map<string,ll>  mp;
map<string ,int>ml;


P a[N];
int c[N],b[N];

int n,m,x,t,y,tot=0;
bool cmp(P x ,P y)
{
	return x.fi<y.fi;
}
int lowbit(int x)
{
    return x&(-x);
}
int add(int x,int val)
{
    for(int i=x;i;i-=lowbit(i))//向下更新
        c[i]+=val;
}
int sum(int x)
{
    int ans=0;
    for(int i=x;i<=n;i+=lowbit(i))//向上求和
        ans+=c[i];
    return ans;
}

int main()
{


	while(scanf("%d",&n)&&n)
	{
		ll ans=0;
		memset(c,0,sizeof c);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i].fi);
			a[i].se=i;

		}
		sort(a+1,a+n+1,cmp);
		for(int i=1;i<=n;i++)
		{
			b[a[i].se]=i;
		}
		for(int i=1;i<=n;i++)
		{
			add(b[i],1);
			ans+=sum(b[i]+1);//找到比当前插入个数大的数目
		}
		printf("%lld\n",ans);

	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值