字符串替换 string (stl) find + replace

题目来源:http://acm.nyist.net/JudgeOnline/problem.php?pid=113

字符串替换

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 2
 
描述
编写一个程序实现将字符串中的所有"you"替换成"we"
 
输入
输入包含多行数据 

每行数据是一个字符串,长度不超过1000 
数据以EOF结束
输出
对于输入的每一行,输出替换后的字符串
样例输入
you are what you do
样例输出
we are what we do

分析:
1:find(string&s, location) , 从 location 位置开始,在字符串中找子串s, 找到返回找到的第一个首字符位置,否则返回 string::npos。

2:replace(location, size, string &s) , 从location 位置开始, 数 size 个 数的 字符串, 用 字符串s 代替。
3: cin>>string s , 遇到空白结束输入 。 如果想输入一行, 则用 getline(cin, S).

代码如下:
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <iostream>
#include <vector>
#include<string>
#include<cstring>
#include<string.h>
#include<set>
#include<queue>
#include<stack>
#include<map>
using namespace std;
typedef long long LL;

int main()
{
    string s;

    while(getline(cin,s)) // 一行输入
    {
        int loc=s.find("you");
        while(loc != string::npos)      // 查找
        {
            s.replace(loc,3,"we");
            loc=s.find("you",loc+1);
        }
        cout<<s<<endl; // 一行输出
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/zn505119020/p/3621006.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值