拓扑排序 --- 反向建图

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9936 Accepted: 2733

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, bN) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4



 

【题目来源】

POJ Founder Monthly Contest – 2008.08.31, windy7926778

 

【题目大意】

有n个球,重量分别为1至n,现在要在上面贴标签,依次输出编号从1到n的球的重量, 要求编号小的球(即靠前的小球)的重量要尽量轻.

 

【题目分析】

反向建图,有向边heavy->light,逆拓扑排序,从重到轻逐一确定。

 

#include<iostream>
#include<cstring>
using namespace std;
bool Map[250][250];
int ans[250];
int in[250];
int T,n,m,i,j,k,a,b,wight;
void topsort()
{
    while(wight>0)
    {
        for(j=n;j>=1;j--)
            if(!in[j])
              break;
        if(!j)
            return;
        in[j]=-1;
        ans[j]=wight--;
        for(k=1;k<=n;k++)
            if(Map[j][k])
               in[k]--;
    }
}
int main()
{
    cin>>T;
    while(T--)
    {
        memset(Map,0,sizeof(Map));
        memset(in,0,sizeof(in));
        cin>>n>>m;
        wight=n;
        while(m--)
        {
            cin>>a>>b;
            if(!Map[b][a])  //反向建图
            {
                Map[b][a]=1;
                in[a]++;
            }
        }
        topsort();
        if(wight>0)
            cout<<"-1"<<endl;
        else
        {
            for(j=1;j<=n;j++)
                if(j==1)
                  cout<<ans[j];
                else cout<<" "<<ans[j];
        cout<<endl;
        }
    }
    return 0;
}

 

 

 

 

 

 

 

 

 

转载于:https://www.cnblogs.com/crazyacking/p/3757184.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值