一、GRE协议概念:
通用路由封装(GenericRoutingEncapsulation,GRE)是网络中通过隧道将通信从一个专用网络传输到另一个专用网络常用到的一个协议。
GRE可以作为***的第三层隧道协议,在协议层之间采用隧道(Tunnel)技术。Tunnel是一个虚拟的点对点的连接,可以看成仅支持点对点连接的虚拟接口,这个接口提供了一条通路,使封装的数据报能够在这个通路上传输,并在一个Tunnel的两端分别对数据报进行封装及解封装。
二、实验要求:通过使用GRE协议使得192.168.1.0/24内网用户可以远程访问172.16.1.0/24网段。
三、配置思路:R1、R2、R3配置相关接口IP,使用EIGRP协议宣告各自公网地址(内网私有地址不能宣告到EIGRP中),R1、R3分别配置NAT使内网网段192.168.1.0/24、172.16.1.0/24可以访问2.2.2.2/24(模拟公网服务器地址),利用Tunnel虚拟隧道技术实现192.168.1.0/24远程访问172.16.1.0/24。
四、实验配置:
R1#
interface Loopback 0
ip address 1.1.1.1 255.255.255.0
interface Tunnel 0
ip address 10.1.1.1 255.255.255.0
tunnel source FastEthernet 0/0指定Tunnel0隧道源
tunnel destination 23.1.1.3指定Tunnel0隧道目的
no shutdown
interface FastEthernet 0/0
ipaddress 12.1.1.1 255.255.255.0
ip nat outside
no shutdown
interface FastEthernet 0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
no shutdown
router eigrp 100
network 12.1.1.0 0.0.0.255
network 1.1.1.0 0.0.0.255
no auto-summary
router rip使用RIP通告隧道地址及内网私有地址
network 10.0.0.0
network 192.168.1.0 no auto-summary
ip nat inside source list 1 interface FastEthernet 0/0 overload
ip route 0.0.0.0 0.0.0.0 12.1.1.2
access-list 1 permit 192.168.1.0 0.0.0.255
------------------------------------------------------------
R2#
interface Loopback 0
ip address 2.2.2.2 255.255.255.0
no shutdown
interface FastEthernet 0/0
ip address 23.1.1.2 255.255.255.0
no shutdown
interface FastEthernet 0/1
ip address 12.1.1.2 255.255.255.0
no shutdown
router eigrp 100
network 12.1.1.0 0.0.0.255
network 2.2.2.0 0.0.0.255
network 23.1.1.0 0.0.0.255
no auto-summary
----------------------------------------------------
R3#
interface Loopback 0
ip address 3.3.3.3255.255.255.0
no shutdown
interface Tunnel 0
ip address 10.1.1.2 255.255.255.0
tunnel source FastEthernet 0/1
tunnel destination 12.1.1.1
no shutdown
interface FastEthernet 0/0
ip address 172.16.1.1 255.255.255.0
ip nat inside
no shutdown
interface FastEthernet 0/1
ip address 23.1.1.3 255.255.255.0
ip nat outside
no shutdown
router eigrp 100
network 23.1.1.00.0.0.255
network 3.3.3.00.0.0.255
no auto-summary
router rip
version 2
network 10.0.0.0
network 172.16.1.0
no auto-summary
ip nat inside source list 1 interface FastEthernet 0/1 overload
ip route 0.0.0.0 0.0.0.0 23.1.1.2
access-list 1 permit 172.16.1.0 0.0.0.255
---------------------------------------------------------
实验结果:
------------------------------------------------
-------------------------------------------------
------------------------------------------------
--------------------------------------------
----------------------------------------
从实验结果可以看出:R1的路由表通过RIP学习到了一条172.16.1.0/24的路由,下一跳为10.1.1.2,即从本地Tunnel0接口发出,R3与R1同理,达到了实验要求的两端私有IP通过GRE Tunnel隧道封装访问的效果。
转载于:https://blog.51cto.com/anvanh/1318459