POJ 3735:Training little cats 联想到矩阵相乘

Training little cats
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11208 Accepted: 2698

Description

Facer's pet cat just gave birth to a brood of little cats. Having considered the health of those lovely cats, Facer decides to make the cats to do some exercises. Facer has well designed a set of moves for his cats. He is now asking you to supervise the cats to do his exercises. Facer's great exercise for cats contains three different moves:
g i : Let the ith cat take a peanut.
e i : Let the ith cat eat all peanuts it have.
s i j : Let the ith cat and jth cat exchange their peanuts.
All the cats perform a sequence of these moves and must repeat it m times! Poor cats! Only Facer can come up with such embarrassing idea. 
You have to determine the final number of peanuts each cat have, and directly give them the exact quantity in order to save them.

Input

The input file consists of multiple test cases, ending with three zeroes "0 0 0". For each test case, three integers nm and k are given firstly, where n is the number of cats and k is the length of the move sequence. The following k lines describe the sequence.
(m≤1,000,000,000, n≤100, k≤100)

Output

For each test case, output n numbers in a single line, representing the numbers of peanuts the cats have.

Sample Input

3 1 6
g 1
g 2
g 2
s 1 2
g 3
e 2
0 0 0

Sample Output

2 0 1

题意是有很多小猫,每个猫一开始有0个花生。

Facer做出g i的动作就是给第i只小猫一个花生。

e i的动作就是让第i只小猫吃掉所有的花生。

s i j的意思是让第i只小猫与第j只小猫交换它们的花生。

这一系列的动作要做m次,问最终每个猫的花生数量。


这个题实际上就是对一个一维数组赋值,交换 经过这样多次的操作之后,问最终这个一位数组的值。

之前没接触过这样的题目,转成二维觉得很新鲜。

g i 就是把第i列的第0行赋值为1。

e i 就是把第i列的所有值赋值为0。

s i j就是交换第i列与第j列的值。


代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;

struct matrix {
	long long m[105][105];
};

long long n, mo, k;
matrix b;

matrix mu(matrix no1, matrix no2)
{
	matrix t;
	memset(t.m, 0, sizeof(t.m));

	long long i, j, k;

	for (i = 0; i <= n; i++)
	{
		for (k = 0; k <= n; k++)
		{
			if (no1.m[i][k])
			{
				for (j = 0; j <= n; j++)
				{
					t.m[i][j] += no1.m[i][k] * no2.m[k][j];
				}
			}
		}
	}
	return t;

}

matrix multi(matrix no, long long x)
{
	memset(b.m, 0, sizeof(b.m));
	long long i;
	for (i = 0; i <= n; i++)
	{
		b.m[i][i] = 1;
	}
	while (x > 0)
	{
		if (x & 1)
			b = mu(b, no);
		x = x >> 1;
		no = mu(no, no);
	}
	return b;
}

int main()
{
	//freopen("i.txt", "r", stdin);
	//freopen("o.txt", "w", stdout);

	long long i, j, temp;
	string test;
	matrix no;

	while (cin >> n >> mo >> k)
	{
		if (n == 0 && mo == 0 && k == 0)
			break;
		memset(no.m, 0, sizeof(no.m));

		for (i = 0; i <= n; i++)
			no.m[i][i] = 1;
		for (i = 1; i <= k; i++)
		{
			cin >> test >> temp;
			if (test == "g")
			{
				no.m[0][temp]++;
			}
			else if (test == "s")
			{
				long long temp2;
				long long b;
				cin >> temp2;

				for (j = 0; j<= n; j++)
				{
					b = no.m[j][temp];
					no.m[j][temp] = no.m[j][temp2];
					no.m[j][temp2] = b;
				}
			}
			else if (test == "e")
			{
				for (j = 0; j <= n; j++)
				{
					no.m[j][temp] = 0;
				}
			}
		}

		no = multi(no, mo);

		cout << no.m[0][1];

		for (i = 2; i <= n; i++)
		{
			cout << " " << no.m[0][i];
		}
		cout << endl;
	}
	//system("pause");
	return 0;
}

 

版权声明:本文为博主原创文章,未经博主允许不得转载。

转载于:https://www.cnblogs.com/lightspeedsmallson/p/4899546.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值