poj 3735Training little cats(矩阵快速幂 完成模拟 注意优化)

Training little cats
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12392 Accepted: 3049

Description

Facer's pet cat just gave birth to a brood of little cats. Having considered the health of those lovely cats, Facer decides to make the cats to do some exercises. Facer has well designed a set of moves for his cats. He is now asking you to supervise the cats to do his exercises. Facer's great exercise for cats contains three different moves:
g i : Let the ith cat take a peanut.
e i : Let the ith cat eat all peanuts it have.
s i j : Let the ith cat and jth cat exchange their peanuts.
All the cats perform a sequence of these moves and must repeat it m times! Poor cats! Only Facer can come up with such embarrassing idea. 
You have to determine the final number of peanuts each cat have, and directly give them the exact quantity in order to save them.

Input

The input file consists of multiple test cases, ending with three zeroes "0 0 0". For each test case, three integers nm and k are given firstly, where n is the number of cats and k is the length of the move sequence. The following k lines describe the sequence.
(m≤1,000,000,000, n≤100, k≤100)

Output

For each test case, output n numbers in a single line, representing the numbers of peanuts the cats have.

Sample Input

3 1 6
g 1
g 2
g 2
s 1 2
g 3
e 2
0 0 0

Sample Output

2 0 1

Source


/*
难点在与怎么将这三种操作转换为矩阵的操作,以题目上的测试数据为例,定义表示猫咪的花生的向量A:

1 0 0 0
A[id]表示第id只猫的初始花生数量,初始时猫咪没有花生,所以都是0。当然,首个元素固定是1,这是为了做乘法用的。

定义单位初始方阵T:

1 0 0 0
0 1 0 0
0 0 1 0
0 0 0 1
定义 R = A * T,那么R[id]表示第id只猫的最终花生数量。上面向量A那个突兀的1就是为了取矩阵T第1行各个值的。

那么

g i   := ++T[0][i]

e i   := set T[i][i] = 0 即将矩阵的元素(i,i)置为0

s i j := swap(T[t][i], T[t][j]) (0<=t<=height) 即将矩阵的i列和j列互换。

T执行m次,结果R = A * Tm 。轮到矩阵的幂出场了,将上次的模板改改即可:
*/
 
#include<iostream>
#include<string>
#include<cstring>
#include<cstdio>
typedef long long ll;
using namespace std;
struct matrix{
	ll mat[150][150];
	matrix()
	{
		memset(mat,0,sizeof(mat));
	}
};
matrix ret,d;
ll n,m,k;
matrix mul(matrix a,matrix b)
{
	memset(ret.mat,0,sizeof(ret.mat));
	for(int i=0;i<=n;i++)
	{
	
		for(int k=0;k<=n;k++)//优化 防止超时 
		if(a.mat[i][k])
		{
		for(int j=0;j<=n;j++)
		{
			ret.mat[i][j]+=a.mat[i][k]*b.mat[k][j];	
		}	
		}
	}
	return ret;
}
matrix ks(matrix a,long long k)
{
	
	if(k==1)
	return a;
	matrix e;
	for(int i=0;i<=n;i++)
	{
		e.mat[i][i]=1;
	}
	if(k==0)
	return e;
	while(k)
	{
		if(k&1)
		{
			e=mul(e,a);
		}
		a=mul(a,a);
		k>>=1;
	}
	return e;
}
int main()
{
	while(~scanf("%lld%lld%lld",&n,&m,&k))
	{
		if(!n&&!m&&!k)break;
		ll a,b;
		memset(d.mat,0,sizeof(d.mat));
		for(int i=0;i<=n;i++)
		d.mat[i][i]=1;
		char op[5];
		while(k--)
		{
			scanf("%s",op);
			if(op[0]=='g')//  第一行表示每只猫的豆豆数  当输入g的时候a猫的豆豆加一  当输入e时 把a猫的所有豆豆清空  交换时把两列的数据全部交换 
			{
				scanf("%lld",&a);
				d.mat[0][a]++;
			}
			else if(op[0]=='e')
			{
				scanf("%lld",&a);
				for(int i=0;i<=n;i++)
				d.mat[i][a]=0;
			}
			else {
				scanf("%lld%lld",&a,&b);
				for(int i=0;i<=n;i++)
				{
					ll t=d.mat[i][a];
					d.mat[i][a]=d.mat[i][b];
					d.mat[i][b]=t;
				}
			}
		}
		matrix ans=ks(d,m);
		printf("%lld",ans.mat[0][1]);
		for(int i=2;i<=n;i++)
		{
			printf(" %lld",ans.mat[0][i]);
		}
		printf("\n");
	}
	return 0;
} 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值