Monthly Expense

Problem Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

 

Input
Line 1: Two space-separated integers:  N and  M 
Lines 2.. N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day
 

Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
 

Sample Input
 
   
7 5 100 400 300 100 500 101 400
 

Sample Output
 
   
500
 

#include<iostream>
#include<cstdio>
using namespace std;
int n,m;
int a[100010];
int fun(int s)   //fun函数是推断当前的mid值能把n分成几组
{                //通过比較q与m的大小,对mid的值进行优化
    int sum=0,q=1;
    for(int i=1;i<=n;i++)//从第一天開始向下遍历每天的花费
    {
        if(sum+a[i]<=s)//前第I天和<=mid时,把他们归为这一组
            sum+=a[i];
        else//否则。第i天做为下一组的第一天
        {
            sum=a[i];
            q++;//组数加一
        }
    }
    if(q>m)//组数大于m,代表mid数值小了,
        return 0;
    return 1;//否则大了
}
int main()
{
    while(~scanf("%d%d",&n,&m)){
        int l,r=0,mid,min=0,sum=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
            if(a[i]>r)r=a[i];
        }
        l=sum;
        int ans=0;
        mid=(l+r)/2;
        while(r<l)
        {
            if(!fun(mid))//假设mid偏小
            {

               r=mid+1;//下界上升
            }
            else//否则
            {
                l=mid-1;//上限下降
            }
             mid=(r+l)/2;
        }
        cout<<mid<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值