poj Simple prefix compression

/*
A:Simple prefix compression

    查看
    提交
    统计
    提问

总时间限制:
    2000ms
内存限制:
    65536kB

描述
    Many databases store the data in the character fields (and especially indices) using prefix compression. This
    technique compresses a sequence of strings A1, ..., AN by the following method: if there are strings Ai = ai,
    1ai,2...ai,p and Ai + 1 = ai+1,1ai+1,2...ai+1,q
    such that for some j ≤ min(p, q) ai,1 = ai+1,1, ai,2 = ai+1,2, ... ai,j = ai+1,j, then the second string is
    stored as [j]ai+1,j+1ai+1,j+2... ai+1,q, where [j] is a single character with code j.

    If j = 0, that is, strings do not have any common prefix, then the second string is prefixed with zero byte,
    and so the total length actually increases.


    Constraints
    1 ≤ N ≤ 10000, 1 ≤ length(Ai) ≤ 255.
输入
    First line of input contains integer number N, with following N lines containing strings A1 ... AN
输出
    Output must contain a single integer -- minimal total length of compressed strings.
样例输入

3
abc
atest
atext

样例输出

    11
*/

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
char s[10005][300];

int main()
{
int n = 0;
int tep = 0;
    scanf("%d", &n);
    for(int i = 0; i < n ; i++)
    {scanf("%s", s[i]);
    //printf("\n%s%d", s[i],strlen(s[i]));
    }
    int sum = strlen(s[0]);
    for(int i = 1; i < n; i++)
    {for(int j = 0; j < strlen(s[i]) && j < strlen(s[i - 1]); j++)
    {
        if(s[i][j] == s[i - 1][j]) tep++;
        else {sum =sum + strlen(s[i]) - tep + 1; tep = 0; break;}
    }
    if(tep) {sum =sum + strlen(s[i]) - tep + 1; tep = 0;}
    }
    printf("%d\n", sum);
}

转载于:https://my.oschina.net/locusxt/blog/132284

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值