Simple prefix compression 问题

</pre><pre name="code" class="cpp">/*
Simple prefix compression
 总时间限制: 2000ms 内存限制: 65536kB
描述
Many databases store the data in the character fields (and especially indices) using prefix compression. This technique compresses a sequence of strings A1, ..., AN by the following method: if there are strings Ai = ai,1ai,2...ai,p and Ai + 1 = ai+1,1ai+1,2...ai+1,q 
such that for some j ≤ min(p, q) ai,1 = ai+1,1, ai,2 = ai+1,2, ... ai,j = ai+1,j, then the second string is stored as [j]ai+1,j+1ai+1,j+2... ai+1,q, where [j] is a single character with code j. 

If j = 0, that is, strings do not have any common prefix, then the second string is prefixed with zero byte, and so the total length actually increases.


Constraints
1 ≤ N ≤ 10000, 1 ≤ length(Ai) ≤ 255.
输入
First line of input contains integer number N, with following N lines containing strings A1 ... AN
输出
Output must contain a single integer -- minimal total length of compressed strings.
样例输入
3
abc
atest
atext
样例输出
11
来源
Northeastern Europe 2003, Far-Eastern Subregion
这周学的是递归,但是这题好像不用递归做直接模拟就可以了,不过这样AC的结果内存较大<span style="color: rgb(35, 31, 23); font-family: 'Lucida Grande', Verdana, 'Bitstream Vera Sans', Arial, sans-serif; font-size: 13.63636302947998px; line-height: 21px;">4564kB,用时<span style="color: rgb(35, 31, 23); font-family: 'Lucida Grande', Verdana, 'Bitstream Vera Sans', Arial, sans-serif; font-size: 13.63636302947998px; line-height: 21px;">370ms</span></span>
作者1300012964
*/
#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
	int n;
	int total = 0;
	int len[10002];
	string str[10002];
	scanf("%d",&n);
	for(int i = 0; i < n; ++i)
	{
		cin >> str[i];
		len[i] = str[i].size();
		total += len[i];   //首先将所有的长度加起来
	}
	for(int i = 0; i < n - 1; ++i)
	{
		for(int j = 0; j < min(len[i],len[i+1]); ++j)
		{
			if(str[i][j] == str[i+1][j])   //碰到相同则长度减一
				--total; 
			else
				break;
		}
		++total;  <span style="white-space:pre">		</span>//减去头字母的影响,加一
	}
	printf("%d\n",total);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值