HDU5014:Number Sequence(贪心)

Number Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2442    Accepted Submission(s): 977
Special Judge


Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● a i ∈ [0,n] 
● a i ≠ a j( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a 0 ⊕ b 0) + (a 1 ⊕ b 1) +···+ (a n ⊕ b n)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 10 5), The second line contains a 0,a 1,a 2,...,a n.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b 0,b 1,b 2,...,b n. There is exactly one space between b i and b i+1 (0 ≤ i ≤ n - 1). Don’t ouput any spaces after b n.
 

Sample Input
 
  
4 2 0 1 4 3
 

Sample Output
 
  
20 1 0 2 3 4
 

Source

题意:找出符合题意的序列b,使得b0^a0 + b1^a1 + b2^a2 +... bn^an最大,其中bi<=n,输出最大值并输出b序列。

思路:异或最大,找出二进制互补的数字即可,要从大到小找。

写法一:

# include <stdio.h>
# include <string.h>
# define MAXN 100000
int a[MAXN+1], b[MAXN+1];
int fun(int num)
{
    int ans = 0;
    while(num)
    {
        num >>= 1;
        ++ans;
    }
    return ans;
}
int main()
{
    long long sum;
    int n;
    while(~scanf("%d",&n))
    {
        sum = 0;
        memset(b, -1, sizeof(b));
        for(int i=0; i<=n; ++i)
            scanf("%d",&a[i]);
        for(int i=n; i>=0; --i)
        {
            if(b[i] == -1)
            {
                int length = fun(i);
                int tmp = ((1<<length)-1)^i;
                b[i] = tmp;
                b[tmp] = i;
                sum += (i^tmp)<<1;
            }
        }
        printf("%lld\n",sum);
        for(int i=0; i<n; ++i)
            printf("%d ",b[a[i]]);
        printf("%d\n",b[a[n]]);

    }
    return 0;
}

写法二:

# include <stdio.h>
# include <string.h>
# define MAXN 100000
int a[MAXN+1], b[MAXN+1];
int main()
{
    long long n;
    while(~scanf("%lld",&n))
    {
        memset(b, -1, sizeof(b));
        for(int i=0; i<=n; ++i)
            scanf("%d",&a[i]);
        for(int i=n; i>=0; --i)
        {
            int ans=0, t=1, s=i;
            if(b[i] == -1)
            {
                while(s)
                {
                    ans += t*((s&1)^1);
                    t <<= 1;
                    s >>= 1;
                }
                b[i] = ans;
                b[ans] = i;
            }
        }
        printf("%lld\n",n*n+n);
        for(int i=0; i<n; ++i)
            printf("%d ",b[a[i]]);
        printf("%d\n",b[a[n]]);

    }
    return 0;
}


转载于:https://www.cnblogs.com/junior19/p/6730028.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值