HDOJ 5014 Number Sequence


找规律


Number Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 303    Accepted Submission(s): 149
Special Judge


Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● a i ∈ [0,n] 
● a i ≠ a j( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a 0 ⊕ b 0) + (a 1 ⊕ b 1) +···+ (a n ⊕ b n)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 10 5), The second line contains a 0,a 1,a 2,...,a n.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b 0,b 1,b 2,...,b n. There is exactly one space between b i and b i+1 (0 ≤ i ≤ n - 1). Don’t ouput any spaces after b n.
 

Sample Input
  
  
4 2 0 1 4 3
 

Sample Output
  
  
20 1 0 2 3 4
 

Source
 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

int n,a[100100],sig[100100];
long long int ans;

int wei(int x)
{
    if(x==0) return 0;
    return log(x*1.)/log(2.0);
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        ans=0;
        memset(sig,-1,sizeof(sig));
        for(int i=n;i>=0;i--) 
        {
            if(n%2==0&&i==0) 
            {
                sig[0]=0;
                continue;
            }
            if(sig[i]!=-1)
            {
                ans+=i^sig[i];
                continue;
            }
            int w=wei(i);    
            w++;
            int fan=((1<<w)-1)^i;
            sig[i]=fan;
            sig[fan]=i;
            ans+=i^sig[i];
        }
        printf("%I64d\n",ans);
        for(int i=0;i<=n;i++)
        {
            int x;
            scanf("%d",&x);
            if(i) putchar(32);
            printf("%d",sig[x]);
        }
        putchar(10);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值