二分查找题

 

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers:  N and  M 
Lines 2..  N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.
 
 
分析 :
 

  题意:给出农夫在n天中每天的花费,要求把这n天分作m组,每组的天数必然是连续的,要求分得各组的花费之和应该尽可能地小,最后输出各组花费之和中的最大值。

  思路:看到各组最小和最大的,果断上二分。很好的一道二分穷举的题

 

代码示例 :

  

#include <iostream>
#include <algorithm>
using namespace std ;

int m , n ;
int a[100010] ;

bool fun ( int key ) {
	int sum = 0 , cnt = 1 ; // cnt 初始值为 1 ,是因为上来默认将所有的集合分为一组  
	for ( int i = 0 ; i < n ; i++ ) {
		sum += a[i] ;
		if ( sum > key ) {
			cnt++ ;
			sum = a[i] ;
		}
	}
	
	if ( cnt <= m ) return true ; // 所选的集合大 , 导致分的份数变小 
	else return false ;
}

int main ( ) {
	int i , j , mid ;
	
	while ( ~scanf ( "%d%d" , &n , &m ) ) {
		int l = 0 , r = 0 ;  
		for ( i = 0 ; i < n ; i++ ) {
			scanf ( "%d" , &a[i] ) ;
			l = max ( l , a[i] ) ;   // 所要二分的区间 下届是所有数中的最大数 , 
			r += a[i] ;              // 上届是所有数的和 
		}
		
		while ( l < r ) {
			mid = l + ( r - l ) / 2 ;
			if ( fun(mid) ) r = mid ;
			else l = mid + 1 ;
		}
		printf ( "%d\n" , r ) ;   // 输出 r 的原因是因为上一次符合题意的mid 给了 r  
	} 
	
	
	return 0 ;
}

  

///****

  这个题还是有一个点 不是很懂 , 就是我二分答案后 在到原区间中去判断 , 并且寻求最优解 , 为什么我要一直按顺序加那些数 , 当达到二分的值 , 跳出一次 , cnt ++ 

///  这个题最后有个地方也要注意下 , 二分的最后是 l 逐渐向 r 靠近 , 但此过程 可能一直都不符合最优解 , 但是此时 r 记录着最近一次的最优解 , 所以此时输出  r 即可 , 若输出 mid 则会出错  

 

 

转载于:https://www.cnblogs.com/ccut-ry/p/7309973.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值