R1
!

!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.1.1 255.255.0.0
 duplex full
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex full
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
!
interface Serial2/0.1 point-to-point
 ip address 10.20.1.2 255.255.0.0
 no arp frame-relay
 frame-relay interface-dlci 102  
!
interface Serial2/0.2 multipoint
 ip address 10.10.1.1 255.255.0.0
 no arp frame-relay
 frame-relay map ip 10.10.1.3 103 broadcast
 frame-relay map ip 10.10.1.5 105 broadcast
 no frame-relay inverse-arp
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
router eigrp 1
 redistribute ospf 1 metric 10000 100 255 1 1500
 passive-interface default
 no passive-interface Serial2/0.1
 network 10.20.1.2 0.0.0.0
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 1 metric 100 metric-type 1 subnets
 network 10.1.1.1 0.0.0.0 area 1
 network 10.10.1.1 0.0.0.0 area 0
 neighbor 10.10.1.3
 neighbor 10.10.1.5
!
router bgp 2
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.10.1.3 remote-as 1
 neighbor 10.10.1.5 remote-as 2
 neighbor 10.20.1.1 remote-as 2
 no auto-summary
!
ip classless
no ip http server
!
!
 
 

R2
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 137.20.20.1 255.255.255.0
 duplex full
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex full
!
interface Serial2/0
 ip address 10.20.1.1 255.255.0.0
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
 frame-relay interface-dlci 201
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
router eigrp 1
 network 10.20.1.1 0.0.0.0
 network 137.20.20.1 0.0.0.0
 no auto-summary
!
router bgp 2
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.10.1.5 remote-as 2
 neighbor 10.20.1.2 remote-as 2
 no auto-summary
!
ip classless
ip route 200.100.100.0 255.255.255.0 10.20.1.2
no ip http server
!
!

 
R3
!

!
interface Loopback0
 ip address 10.33.1.1 255.255.255.0
!
interface Loopback1
 ip address 10.33.2.1 255.255.255.0
!
interface Loopback2
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex full
!
interface Serial2/0
 ip address 10.10.1.3 255.255.0.0
 encapsulation frame-relay
 ip ospf priority 0
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
 frame-relay map ip 10.10.1.1 301 broadcast
 frame-relay map ip 10.10.1.5 301 broadcast
 no frame-relay inverse-arp
!
interface Serial2/1
 ip address 173.168.40.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
 frame-relay map ip 173.168.40.2 314 broadcast
 no frame-relay inverse-arp
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
router ospf 1
 log-adjacency-changes
 area 33 range 10.33.0.0 255.255.252.0
 redistribute connected metric 500 metric-type 1 subnets
 network 10.10.1.3 0.0.0.0 area 0
 network 10.33.1.1 0.0.0.0 area 33
 network 10.33.2.1 0.0.0.0 area 33
 default-information originate metric 500 metric-type 1
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.10.1.1 remote-as 2
 neighbor 173.168.40.2 remote-as 1
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 173.168.40.2
no ip http server
!
 

R4
!
!
interface Loopback0
 ip address 44.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 41.1.1.2 255.255.255.0
!
interface Loopback2
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 200.100.100.1 255.255.255.0
 duplex full
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex full
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
interface Serial2/1
 ip address 173.168.40.2 255.255.0.0
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
 frame-relay map ip 173.168.40.1 413 broadcast
 no frame-relay inverse-arp
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
router rip
 version 2
 network 41.0.0.0
 no auto-summary
!
router bgp 1
 no synchronization
 bgp router-id 4.4.4.4
 bgp log-neighbor-changes
 network 44.1.1.0 mask 255.255.255.0
 redistribute static
 redistribute rip
 neighbor 173.168.40.1 remote-as 1
 no auto-summary
!
ip default-gateway 173.168.40.3
ip classless
ip route 4.4.4.0 255.255.255.0 Null0
!

R5
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex full
!
interface Serial2/0
 ip address 10.10.1.5 255.255.0.0
 encapsulation frame-relay
 ip ospf priority 0
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
 frame-relay map ip 10.10.1.1 501 broadcast
 frame-relay map ip 10.10.1.3 501 broadcast
 no frame-relay inverse-arp
!
interface Serial2/1
 ip address 11.1.1.5 255.255.0.0
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
 frame-relay map ip 11.1.1.6 516 broadcast
 no frame-relay inverse-arp
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
router ospf 1
 log-adjacency-changes
 network 10.10.1.5 0.0.0.0 area 0
 network 11.1.1.5 0.0.0.0 area 0
!
router bgp 2
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.10.1.1 remote-as 2
 neighbor 10.20.1.1 remote-as 2
 neighbor 11.1.1.6 remote-as 3
 neighbor 11.1.1.6 route-map FILTER out
 no auto-summary
!
ip classless
no ip http server
!
!
access-list 10 permit 4.0.0.0
access-list 20 permit any
!
route-map FILTER deny 10
 match ip address 10
!
route-map FILTER permit 20
 match ip address 2
 
 
 
R6
!
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.2.1.1 255.255.0.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 pass
 ip ospf hello-interval 45
 ip ospf transmit-delay 10
 duplex full
!        
interface FastEthernet1/0
 no ip address
 shutdown
 duplex full
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
interface Serial2/1
 ip address 11.1.1.6 255.255.0.0
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 no arp frame-relay
 frame-relay map ip 11.1.1.5 615 broadcast
 no frame-relay inverse-arp
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
 clock rate 64000
!
router ospf 10
 log-adjacency-changes
 passive-interface Serial2/1
 network 12.2.1.1 0.0.0.0 area 0
 default-information originate always metric 20
!
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 redistribute ospf 10 match internal external 1 external 2
 redistribute ospf 2 match internal external 1 external 2 route-map LOCAL_PREF
 neighbor 11.1.1.5 remote-as 2
 neighbor 12.2.1.2 remote-as 3
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 11.1.1.5
no ip http server
!
!
access-list 1 permit 0.0.0.0
access-list 2 permit any
!
route-map LOCAL_PREF permit 10
 match ip address 1
!
route-map LOCAL_PREF permit 20
 match ip address 2
 
R7(实在没有更多的路由模拟器了,找个3层交换机代替,相应接口也做了更改)
!
!

interface Loopback0
 ip address 7.7.7.7 255.255.255.255
!
!
!
interface FastEthernet0/6
 no switchport
 ip address 12.2.1.2 255.255.0.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 pass
 ip ospf hello-interval 45
 ip ospf transmit-delay 10
!
interface FastEthernet0/7
!
interface FastEthernet0/8
 no switchport
 ip address 12.4.1.1 255.255.0.0
!
interface FastEthernet0/9
 no switchport
 ip address 12.3.1.1 255.255.0.0
!
router ospf 10
 log-adjacency-changes
 redistribute rip metric 100 metric-type 1 subnets
 network 12.2.1.2 0.0.0.0 area 0
 network 12.3.1.1 0.0.0.0 area 0
 network 12.4.1.1 0.0.0.0 area 0
!
router rip
 version 2
 network 7.0.0.0
 no auto-summary
!
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 redistribute ospf 10
 redistribute rip
 neighbor 12.2.1.1 remote-as 3
 no auto-summary
!

校验
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.10.1.3 to network 0.0.0.0
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     137.20.0.0/24 is subnetted, 1 subnets
D       137.20.20.0 [90/2172416] via 10.20.1.1, 02:03:19, Serial2/0.1
     3.0.0.0/32 is subnetted, 1 subnets
O E1    3.3.3.3 [110/564] via 10.10.1.3, 01:28:33, Serial2/0.2
     4.0.0.0/24 is subnetted, 1 subnets
B       4.4.4.0 [20/0] via 10.10.1.3, 00:18:21
     7.0.0.0/32 is subnetted, 1 subnets
B       7.7.7.7 [200/0] via 11.1.1.6, 00:22:14
     173.168.0.0/24 is subnetted, 1 subnets
O E1    173.168.40.0 [110/564] via 10.10.1.3, 01:28:33, Serial2/0.2
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       10.10.0.0/16 is directly connected, Serial2/0.2
C       10.1.0.0/16 is directly connected, FastEthernet0/0
C       10.20.0.0/16 is directly connected, Serial2/0.1
O IA    10.33.0.0/22 [110/65] via 10.10.1.3, 02:02:00, Serial2/0.2
     41.0.0.0/24 is subnetted, 1 subnets
B       41.1.1.0 [20/0] via 10.10.1.3, 00:18:21
     11.0.0.0/16 is subnetted, 1 subnets
O       11.1.0.0 [110/128] via 10.10.1.5, 02:02:00, Serial2/0.2
     12.0.0.0/16 is subnetted, 3 subnets
B       12.4.0.0 [200/2] via 11.1.1.6, 00:22:14
B       12.2.0.0 [200/0] via 11.1.1.6, 00:22:14
B       12.3.0.0 [200/2] via 11.1.1.6, 00:22:14
     44.0.0.0/24 is subnetted, 1 subnets
B       44.1.1.0 [20/0] via 10.10.1.3, 00:18:21
O*E1 0.0.0.0/0 [110/564] via 10.10.1.3, 01:30:24, Serial2/0.2
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.20.1.2 to network 0.0.0.0
     137.20.0.0/24 is subnetted, 1 subnets
C       137.20.20.0 is directly connected, FastEthernet0/0
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
D EX    3.3.3.3 [170/2195456] via 10.20.1.2, 01:28:56, Serial2/0
     4.0.0.0/24 is subnetted, 1 subnets
B       4.4.4.0 [200/0] via 10.10.1.3, 00:18:43
S    200.100.100.0/24 [1/0] via 10.20.1.2
     7.0.0.0/32 is subnetted, 1 subnets
B       7.7.7.7 [200/0] via 11.1.1.6, 00:22:36
     173.168.0.0/24 is subnetted, 1 subnets
D EX    173.168.40.0 [170/2195456] via 10.20.1.2, 01:28:56, Serial2/0
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D EX    10.10.0.0/16 [170/2195456] via 10.20.1.2, 02:03:42, Serial2/0
D EX    10.1.0.0/16 [170/2195456] via 10.20.1.2, 02:03:42, Serial2/0
C       10.20.0.0/16 is directly connected, Serial2/0
D EX    10.33.0.0/22 [170/2195456] via 10.20.1.2, 02:02:22, Serial2/0
     41.0.0.0/24 is subnetted, 1 subnets
B       41.1.1.0 [200/0] via 10.10.1.3, 00:18:44
     11.0.0.0/16 is subnetted, 1 subnets
D EX    11.1.0.0 [170/2195456] via 10.20.1.2, 02:02:23, Serial2/0
     12.0.0.0/16 is subnetted, 3 subnets
B       12.4.0.0 [200/2] via 11.1.1.6, 00:22:37
B       12.2.0.0 [200/0] via 11.1.1.6, 00:22:37
B       12.3.0.0 [200/2] via 11.1.1.6, 00:22:37
     44.0.0.0/24 is subnetted, 1 subnets
B       44.1.1.0 [200/0] via 10.10.1.3, 00:18:44
D*EX 0.0.0.0/0 [170/2195456] via 10.20.1.2, 01:30:47, Serial2/0

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 173.168.40.2 to network 0.0.0.0
     137.20.0.0/24 is subnetted, 1 subnets
O E1    137.20.20.0 [110/164] via 10.10.1.1, 02:02:52, Serial2/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback2
     4.0.0.0/24 is subnetted, 1 subnets
B       4.4.4.0 [200/0] via 173.168.40.2, 00:38:43
     7.0.0.0/32 is subnetted, 1 subnets
B       7.7.7.7 [20/0] via 10.10.1.5, 00:19:13
     173.168.0.0/24 is subnetted, 1 subnets
C       173.168.40.0 is directly connected, Serial2/1
     10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
C       10.10.0.0/16 is directly connected, Serial2/0
O IA    10.1.0.0/16 [110/65] via 10.10.1.1, 02:02:52, Serial2/0
O E1    10.20.0.0/16 [110/164] via 10.10.1.1, 02:02:53, Serial2/0
C       10.33.2.0/24 is directly connected, Loopback1
C       10.33.1.0/24 is directly connected, Loopback0
O       10.33.0.0/22 is a summary, 02:12:38, Null0
     41.0.0.0/24 is subnetted, 1 subnets
B       41.1.1.0 [200/0] via 173.168.40.2, 00:38:44
     11.0.0.0/16 is subnetted, 1 subnets
O       11.1.0.0 [110/128] via 10.10.1.5, 02:02:53, Serial2/0
     12.0.0.0/16 is subnetted, 3 subnets
B       12.4.0.0 [20/0] via 10.10.1.5, 00:19:14
B       12.2.0.0 [20/0] via 10.10.1.5, 00:19:14
B       12.3.0.0 [20/0] via 10.10.1.5, 00:19:14
     44.0.0.0/24 is subnetted, 1 subnets
B       44.1.1.0 [200/0] via 173.168.40.2, 00:38:44
S*   0.0.0.0/0 [1/0] via 173.168.40.2
r4#i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR
Gateway of last resort is 173.168.40.1 to network 0.0.0.0
     4.0.0.0/24 is subnetted, 1 subnets
S       4.1.1.0 is directly connected, Null0
     173.168.0.0/24 is subnetted, 1 subnets
C       173.168.40.0 is directly connected, Serial0
B    12.0.0.0/8 [200/0] via 10.10.1.1, 00:28:47
     41.0.0.0/24 is subnetted, 1 subnets
C       41.1.1.0 is directly connected, Loopback1
     44.0.0.0/24 is subnetted, 1 subnets
C       44.1.1.0 is directly connected, Loopback0
B    177.1.0.0/16 [200/0] via 10.10.1.1, 00:28:47
C    200.200.200.0/24 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 173.168.40.1

R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.10.1.3 to network 0.0.0.0
     137.20.0.0/24 is subnetted, 1 subnets
O E1    137.20.20.0 [110/164] via 10.10.1.1, 02:03:22, Serial2/0
     3.0.0.0/32 is subnetted, 1 subnets
O E1    3.3.3.3 [110/564] via 10.10.1.3, 01:29:56, Serial2/0
     4.0.0.0/24 is subnetted, 1 subnets
B       4.4.4.0 [200/0] via 10.10.1.3, 00:19:43
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
     7.0.0.0/32 is subnetted, 1 subnets
B       7.7.7.7 [20/0] via 11.1.1.6, 00:23:36
     173.168.0.0/24 is subnetted, 1 subnets
O E1    173.168.40.0 [110/564] via 10.10.1.3, 01:29:55, Serial2/0
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       10.10.0.0/16 is directly connected, Serial2/0
O IA    10.1.0.0/16 [110/65] via 10.10.1.1, 02:03:22, Serial2/0
O E1    10.20.0.0/16 [110/164] via 10.10.1.1, 02:03:22, Serial2/0
O IA    10.33.0.0/22 [110/65] via 10.10.1.3, 02:03:22, Serial2/0
     41.0.0.0/24 is subnetted, 1 subnets
B       41.1.1.0 [200/0] via 10.10.1.3, 00:19:43
     11.0.0.0/16 is subnetted, 1 subnets
C       11.1.0.0 is directly connected, Serial2/1
     12.0.0.0/16 is subnetted, 3 subnets
B       12.4.0.0 [20/2] via 11.1.1.6, 00:23:36
B       12.2.0.0 [20/0] via 11.1.1.6, 00:23:36
B       12.3.0.0 [20/2] via 11.1.1.6, 00:23:36
     44.0.0.0/24 is subnetted, 1 subnets
B       44.1.1.0 [200/0] via 10.10.1.3, 00:19:43
O*E1 0.0.0.0/0 [110/564] via 10.10.1.3, 01:31:47, Serial2/0

R6#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 11.1.1.5 to network 0.0.0.0
     4.0.0.0/24 is subnetted, 1 subnets
B       4.4.4.0 [20/0] via 11.1.1.5, 00:21:09
     6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback0
     7.0.0.0/32 is subnetted, 1 subnets
O E1    7.7.7.7 [110/101] via 12.2.1.2, 00:26:08, FastEthernet0/0
     41.0.0.0/24 is subnetted, 1 subnets
B       41.1.1.0 [20/0] via 11.1.1.5, 00:21:09
     11.0.0.0/16 is subnetted, 1 subnets
C       11.1.0.0 is directly connected, Serial2/1
     12.0.0.0/16 is subnetted, 3 subnets
O       12.4.0.0 [110/2] via 12.2.1.2, 00:26:08, FastEthernet0/0
C       12.2.0.0 is directly connected, FastEthernet0/0
O       12.3.0.0 [110/2] via 12.2.1.2, 00:26:09, FastEthernet0/0
     44.0.0.0/24 is subnetted, 1 subnets
B       44.1.1.0 [20/0] via 11.1.1.5, 00:21:10
S*   0.0.0.0/0 [1/0] via 11.1.1.5

R7#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 12.2.1.1 to network 0.0.0.0
     4.0.0.0/24 is subnetted, 1 subnets
B       4.4.4.0 [200/0] via 11.1.1.5, 00:21:16
     7.0.0.0/32 is subnetted, 1 subnets
C       7.7.7.7 is directly connected, Loopback0
     41.0.0.0/24 is subnetted, 1 subnets
B       41.1.1.0 [200/0] via 11.1.1.5, 00:21:16
     12.0.0.0/16 is subnetted, 3 subnets
C       12.4.0.0 is directly connected, FastEthernet0/8
C       12.2.0.0 is directly connected, FastEthernet0/6
C       12.3.0.0 is directly connected, FastEthernet0/9
     44.0.0.0/24 is subnetted, 1 subnets
B       44.1.1.0 [200/0] via 11.1.1.5, 00:21:16
O*E2 0.0.0.0/0 [110/20] via 12.2.1.1, 00:26:51, FastEthernet0/6