Funny Sheep(思维)

Problem 1606 - Funny Sheep
Time Limit: 1000MS    Memory Limit: 65536KB    Total Submit: 612  Accepted: 169  Special Judge: No
Description

There are N+1 rows and M+1 columns fence with N*M grids on the grassland. Each grid has a sheep. In order to let the sheep together, we need to dismantle the fence. Every time you can remove a row or a column of fences. What’s the least number of times to reach the goal? 

Input
There are multiple test cases. The first line of each case contains two integers N and M. (1≤N,M≤1000)
Output
For each case, output the answer in a line.
Sample Input
1 2 2 2
Sample Output
1   2
题解:一个N*M的网格,每个格子里都有一头羊,现在要把所有羊聚集在一起。。。要通过拆网格,每次拆一行或者一列,问最小次数;
刚开始没想到要拆四周的墙,各种傻逼。。。最后终于发现了拆列,拆行,或者拆中间;拆行或者列是N,M只需要留一个就行了;或者N-1+M-1;
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
typedef long long LL;
int main(){
    int N, M;
    while(~scanf("%d%d",&N,&M)){
        int ans = min(N,M);
        ans=min(ans,N-1+M-1);
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值