HDU 5319

Painter

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 816    Accepted Submission(s): 376


Problem Description
Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.
 

Input
The first line is an integer T describe the number of test cases.
Each test case begins with an integer number n describe the number of rows of the drawing board.
Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.
1<=n<=50

The number of column of the rectangle is also less than 50.


Output
Output an integer as described in the problem description.

 
Sample Input
2
4
RR.B
.RG.
.BRR
B..R
4
RRBB
RGGB
BGGR
BBRR
 


Sample Output
3

6

//遍历一遍地图 当碰到R的时候这一斜对角线都变为'.' 当碰到G的时候变为B

// 由于R和B 的方向不同 要推断两次  对角线有可能没有所有画完  一条对角线有可能画多次 

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
char s[60][60];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        getchar();
        for(int i=0;i<n;i++)
            gets(s[i]);
        int ans=0;
        int len=strlen(s[0]);
        for(int i=0;i<n;i++)
        {
            for(int k=0;k<len;k++)  //注意长度 
            {
                int t=k;
                if((s[i][k]=='R')||(s[i][k]=='G'))
                {
                    ans++;
                    for(int j=i;j<n&&t<len;j++)
                    {

                        if(s[j][t]=='.'||s[j][t]=='B')
                            break;
                        if(s[j][t]=='G')
                            s[j][t]='B';
                        else if(s[j][t]=='R')
                            s[j][t]='.';
                        t++;
                    }
                }
                t=k;
                if((s[i][k]=='B')||(s[i][k]=='G'))
                {
                    ans++;
                    for(int j=i;j<n&&t>=0;j++)
                    {

                        if(s[j][t]=='.'||s[j][t]=='R')
                            break;
                        if(s[j][t]=='G')
                            s[j][t]='R';
                        else if(s[j][t]=='B')
                            s[j][t]='.';
                        t--;
                    }
                }
            }

        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值