R1
|
RIP
|
R2
|
OSPF
|
R3
R1#show running-config
!
hostname R1
!
interface Loopback0
ip address 10.0.0.1 255.0.0.0
!
interface Serial1/1
ip address 20.0.0.1 255.0.0.0
serial restart-delay 0
!
router rip
network 10.0.0.0
network 20.0.0.0
default-information originate
!
ip route 0.0.0.0 0.0.0.0 20.0.0.2
|
RIP
|
R2
|
OSPF
|
R3
R1#show running-config
!
hostname R1
!
interface Loopback0
ip address 10.0.0.1 255.0.0.0
!
interface Serial1/1
ip address 20.0.0.1 255.0.0.0
serial restart-delay 0
!
router rip
network 10.0.0.0
network 20.0.0.0
default-information originate
!
ip route 0.0.0.0 0.0.0.0 20.0.0.2
R2#show running-config
!
hostname R2
!
interface Serial1/0
ip address 20.0.0.2 255.0.0.0
serial restart-delay 0
!
interface Serial1/1
ip address 30.0.0.1 255.0.0.0
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 30.0.0.0 0.0.0.255 area 0
!
router rip
network 20.0.0.0
!
hostname R2
!
interface Serial1/0
ip address 20.0.0.2 255.0.0.0
serial restart-delay 0
!
interface Serial1/1
ip address 30.0.0.1 255.0.0.0
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 30.0.0.0 0.0.0.255 area 0
!
router rip
network 20.0.0.0
R3#show running-config
!
hostname R3
!
interface Loopback0
ip address 40.0.0.1 255.0.0.0
!
interface Serial1/0
ip address 30.0.0.2 255.0.0.0
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 30.0.0.0 0.0.0.255 area 0
network 40.0.0.0 0.0.0.255 area 0
default-information originate
!
ip route 0.0.0.0 0.0.0.0 30.0.0.1
!
hostname R3
!
interface Loopback0
ip address 40.0.0.1 255.0.0.0
!
interface Serial1/0
ip address 30.0.0.2 255.0.0.0
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 30.0.0.0 0.0.0.255 area 0
network 40.0.0.0 0.0.0.255 area 0
default-information originate
!
ip route 0.0.0.0 0.0.0.0 30.0.0.1
R1#show ip rou
C 20.0.0.0/8 is directly connected, Serial1/1
C 10.0.0.0/8 is directly connected, Loopback0
S* 0.0.0.0/0 [1/0] via 20.0.0.2
R2#show ip rou
C 20.0.0.0/8 is directly connected, Serial1/0
40.0.0.0/32 is subnetted, 1 subnets
O 40.0.0.1 [110/65] via 30.0.0.2, 00:00:16, Serial1/1
R 10.0.0.0/8 [120/1] via 20.0.0.1, 00:00:16, Serial1/0
C 30.0.0.0/8 is directly connected, Serial1/1
O*E2 0.0.0.0/0 [110/1] via 30.0.0.2, 00:00:16, Serial1/1
C 20.0.0.0/8 is directly connected, Serial1/0
40.0.0.0/32 is subnetted, 1 subnets
O 40.0.0.1 [110/65] via 30.0.0.2, 00:00:16, Serial1/1
R 10.0.0.0/8 [120/1] via 20.0.0.1, 00:00:16, Serial1/0
C 30.0.0.0/8 is directly connected, Serial1/1
O*E2 0.0.0.0/0 [110/1] via 30.0.0.2, 00:00:16, Serial1/1
R3#show ip rou
C 40.0.0.0/8 is directly connected, Loopback0
C 30.0.0.0/8 is directly connected, Serial1/0
S* 0.0.0.0/0 [1/0] via 30.0.0.1
C 40.0.0.0/8 is directly connected, Loopback0
C 30.0.0.0/8 is directly connected, Serial1/0
S* 0.0.0.0/0 [1/0] via 30.0.0.1
转载于:https://blog.51cto.com/marke721/21445