C - Probability HDU - 2131

Mickey is interested in probability recently. One day , he played a game which is about probability with mini.First mickey gives a letter and a word to mini.Then mini calculate the probability that the letter appears in the word.For example,give you the letter "a" and the word "apple". the probability of this case is 0.20000.

InputThe input contains several test cases. Each test case consists of a letter and a word.The length of the word is no longer than 200.OutputFor each test case, print the probability rounded to five digits after the decimal point.
Sample Input

a apple
c Candy
a banana

Sample Output

0.20000
0.20000
0.50000
注意都化为大小写字母就可以了
#include<stdio.h>
#include<string.h>
int main()
{
char ch[201];
char ch1;
int len,ans; while (scanf("%c", &ch1)!=EOF)
{
if (ch1 < 'a') ch1 += 'a' - 'A';
ans = 0;
getchar();
scanf("%s", ch);
getchar();
len = strlen(ch);
for (int i = 0; i < len; i++)
{
if (ch[i] == ch1 || ch1 == ch[i] + 'a' - 'A') ans++;
}
printf("%.5lf\n", (double)ans / len);
}
return 0;
}

转载于:https://www.cnblogs.com/damaoranran/p/8778252.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值