HDU 2131 Probability

77 篇文章 0 订阅
40 篇文章 0 订阅

Probability

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5634    Accepted Submission(s): 2811


Problem Description
Mickey is interested in probability recently. One day , he played a game which is about probability with mini.First mickey gives a letter and a word to mini.Then mini calculate the probability that the letter appears in the word.For example,give you the letter "a" and the word "apple". the probability of this case is 0.20000.
 

Input
The input contains several test cases. Each test case consists of a letter and a word.The length of the word is no longer than 200.
 

Output
For each test case, print the probability rounded to five digits after the decimal point.
 

Sample Input
  
  
a apple c Candy a banana
 

Sample Output
  
  
0.20000 0.20000 0.50000
题目本质是统计该字符在字符串出现的次数,只要注意大小写算一个字符就可以了。

代码如下:

<span style="font-size:14px;">#include <stdio.h>
#include <string.h>
#include <math.h>
int main()
{
	char ch,str[205];
	int i,j;
	while(~scanf("%c %s%*c",&ch,str))
	{
		int len=strlen(str),index=0;
		for(i=0;i<len;i++)
			if(ch==str[i] || fabs(ch-str[i])==32)
				index++;
		double sum=index*1.0/len;
		printf("%.5lf\n",sum);
	}
	
	return 0;
}</span>



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值