HDU_2131Probability

Mickey is interested in probability recently. One day , he played a game which is about probability with mini.First mickey gives a letter and a word to mini.Then mini calculate the probability that the letter appears in the word.For example,give you the letter "a" and the word "apple". the probability of this case is 0.20000.
 

Input
The input contains several test cases. Each test case consists of a letter and a word.The length of the word is no longer than 200.
 

Output
For each test case, print the probability rounded to five digits after the decimal point.
 

Sample Input
  
  
a apple c Candy a banana
 

Sample Output
  
  
0.20000 0.20000 0.50000
  代码:
    #include<stdio.h>
    #include<math.h>
    #include<string.h>
    #include<algorithm>
    #include<ctype.h>
    using namespace std;
    int main()
    {
        int i,len;
        char a[201],b;
        double n;
        while(scanf("%c %s",&b,a)!=EOF){
            len=strlen(a);
              n=0;
            for(i=0;i<len;i++){
                if(tolower(b)==tolower(a[i]))
                    n++;
            }
            printf("%.5lf\n",n/len);
            getchar();
        }
        return 0;
    }

思路解析:
无论"b"是大小写的字母,“a”中的任意一个“b”是大小写,只要有就加一;
所以把“a”和“b”都转化成一种形式(代码转化为了小写形式,也可以是大写形式),便于处理。

功 能: 把字符转换成小写字母,非字母字符不做出处理
头文件:在VC6.0可以是ctype.h或者stdlib.h,常用ctype.h
用 法: int tolower(int c);
#include <iostream>
#include <string>
#include <ctype.h>
using namespace std;
int main()
{
    string str= "PROBABILITY";
    for (int i=0; i < str.size(); i++)
       str[i] = tolower(str[i]);
    cout<<str<<endl;
    return 0;
}
输出:probability



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值